Opened 10 years ago

Closed 7 years ago

#2591 closed defect (obsolete)

Dragging an activity icon over another and clicking journal icon launches an activity

Reported by: m_anish Owned by:
Priority: Low Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Minor Keywords: dx2
Cc: Distribution/OS: Dextrose
Bug Status: Unconfirmed

Description (last modified by m_anish)

Testcase:

  • Go to favorites view (ring layout)
  • Make sure no other activity is running
  • Drag an activity icon (A) over another icon (B)
  • Click the journal icon under the XO guy
  • Activity (A) starts instead

This bug is present in both Dextrose and the latest sugar releases.

Attachments (1)

bug-2591.gif (420.4 KB) - added by m_anish 10 years ago.
bug reproduced in jhbuild (fast h/w required to play gif image)

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by walter

I cannot reproduce this on the 0.90.1 Sugar on Fedora 14 or in sugar-jhbuild.

comment:2 Changed 10 years ago by m_anish

  • Description modified (diff)
  • Summary changed from [dx2] Favorites view | Dragging an activity icon over another results in wrong activity starting up to [dx2] Favorites view | Dragging an activity icon over another and clicking journal icon launches an activity!

comment:3 Changed 10 years ago by m_anish

  • Bug Status changed from Unconfirmed to New

comment:4 Changed 10 years ago by walter

This bug is in the Ring view, but not the Random view (which is why I could not reproduce it earlier). It is a bug in Sugar 0.84 as well as recent builds, e.g., Build 860 on an XO 1.5

comment:5 Changed 10 years ago by m_anish

  • Priority changed from Unspecified by Maintainer to Low
  • Severity changed from Unspecified to Minor

Changed 10 years ago by m_anish

bug reproduced in jhbuild (fast h/w required to play gif image)

comment:6 Changed 8 years ago by dnarvaez

  • Summary changed from [dx2] Favorites view | Dragging an activity icon over another and clicking journal icon launches an activity! to Dragging an activity icon over another and clicking journal icon launches an activity

comment:7 Changed 8 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:8 Changed 7 years ago by FGrose

  • Resolution set to obsolete
  • Status changed from new to closed

Dragging in the Favorites.ringlayout has been disabled.
The described problem does not seem to occur in the randomlayout view.

Note: See TracTickets for help on using tickets.