Opened 10 years ago

Closed 10 years ago

#2575 closed defect (fixed)

PJ Lite issues

Reported by: RafaelOrtiz Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: ActivityTeam Version: Unspecified
Severity: Unspecified Keywords:
Cc: mulawa1 Distribution/OS: Unspecified
Bug Status: Resolved

Description (last modified by mulawa1)

From the NZ testing team.

PJ lite & PJ
PJ lite is jigsaw puzzles from photos
can see the window frame thing - unSugar like
we are having cursor issues in PJ lite on the XO-1.0s - there is a bit of
delay so you end up letting go of puzzle piece and it lands somewhere else -
still have issues using USB mouse
would be cool if you could add more photos (like ones you take yourself) to
the PJ and PJ lite activity
the PJ lite game has 12 piece puzzles and the PJ game has 40 pieces and lets
you choose if the pieces are up the right way or mixed directions - that
makes for good levels for learners and more advanced

we also having some issues with some info on frames per second appearing in
front of PJ activity and Rectangles activity - right in the middle of the
screen
took photo of the writing
restarting the activities resolved the writing on the screen issue -
happened on both XO-1 and XO-1.5

Change History (8)

comment:1 Changed 10 years ago by RafaelOrtiz

  • Component changed from untriaged to ActivityTeam
  • Owner set to garycmartin

comment:2 Changed 10 years ago by RafaelOrtiz

we also having some issues with some info on frames per second appearing in

front of PJ activity and Rectangles activity - right in the middle of the
screen
took photo of the writing
restarting the activities resolved the writing on the screen issue -

This is a feature of sugargames based activities.

comment:3 follow-up: Changed 10 years ago by mulawa1

I am concerned about the cursor issues and hope someone will identify what the problem is. Maybe I should abandon my fake cursor and just accept the default X-cursor?

The "info on frames per second" is triggered by pressing both buttons - repeating the action will clear it. Maybe I'll have to drop this from my activities - it is simply for my own convenience.

Don't understand "can see the window frame thing - unSugar like".

Re: own photos - there is already a Jigsaw activity that offers this facility.

Peter

comment:4 in reply to: ↑ 3 Changed 10 years ago by garycmartin

Replying to mulawa1:

I am concerned about the cursor issues and hope someone will identify what the problem is. Maybe I should abandon my fake cursor and just accept the default X-cursor?

It it possible that the tester had one or more badly behaving activities eating the CPU in the background? This high load would cause a jumpy software cursor. FWIW I recently made improvements to Physics (based on pygame) to make sure it does minimal work when not in focus (see its repository in git.sugarlabs.org, it just needed to register for a few events and have a minimal idle loop).

comment:5 Changed 10 years ago by mulawa1

  • Cc mulawa1 added

I have created a version PJ Lite that doesn't use a fake cursor and sent it to the NZ team for testing. I was interested to observe that on my XO-1 (.84) a picked up piece lagged behind the cursor. Here it is if anyone else wants to try it:

http://mulawa.net/olpc/PJLite-6.xo

@Gary: I have implemented code to make sure my activity doesn't eat up CPU (I know that's not what you were suggesting) but my activities tend to throw many images to the screen and of course mouse movement triggers a redraw. Maybe I might have to investigate making use of update rather than flip.

Peter

comment:6 Changed 10 years ago by mulawa1

  • Description modified (diff)
  • seeta_dev set to mulawa1
  • Summary changed from Pj lite issues to PJ Lite issues

comment:7 Changed 10 years ago by mulawa1

Another version:

http://mulawa.net/olpc/PJLite-7.xo

This one toggles the fake cursor by pressing the "A" (for Arrow) key - this may turn out to be the best solution seeing the problem isn't as severe on all XOs.

I have a growing suspicion that my activities are too graphically intense for the XO.

Peter

comment:8 Changed 10 years ago by mulawa1

  • Bug Status changed from Unconfirmed to Resolved
  • Resolution set to fixed
  • Status changed from new to closed

Issue fully resolved with latest version:

http://activities.sugarlabs.org/en-US/sugar/addon/4385

Peter

Note: See TracTickets for help on using tickets.