Opened 10 years ago

Closed 10 years ago

#2529 closed defect (fixed)

WikipediaEN and Wikipedia cannot coexist

Reported by: martin.langhoff Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.90.x
Severity: Major Keywords:
Cc: quozl, alsroot, erikos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

This is due to changes related to #897 -- present in 0.84, 0.88 and 0.90. The patch is reverted in latest 0.84 (for the OLPC 10.1.3 release).

More info at http://lists.sugarlabs.org/archive/sugar-devel/2010-December/029129.html

The problem is -- as discussed a bit in #897 -- get_bundle() is used internally for calls that require precision. The desired DWIM belongs to a user-friendly function that sugar-launch should call.

Desired -- a patch that achieves the DWIM desired in #897 without breaking sugar internals.

Change History (3)

comment:1 Changed 10 years ago by martin.langhoff

  • Cc quozl alsroot erikos added

comment:2 Changed 10 years ago by erikos

Based on http://dev.laptop.org/ticket/9189 we should revert 4a3416b9acdfdd533ee2d69633f1383476db5e71 in the sugar repository.

comment:3 Changed 10 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

I reverted the patch from the master and the 0.90 branch.

Aleksey wants to enhance the search functionality (moving it to another method), which can be handled in a separate approach.

Note: See TracTickets for help on using tickets.