Opened 10 years ago

Closed 8 years ago

#2526 closed defect (fixed)

Message-IDs are not unique, causing notifications to be "lost"

Reported by: sascha_silbe Owned by: sascha_silbe
Priority: High Milestone:
Component: bugs.sugarlabs.org Version:
Severity: Critical Keywords:
Cc: Distribution/OS:
Bug Status: New

Description

I finally figured out why I'm missing some of the notifications mails:
Trac sometimes "recycles" Message-IDs, causing my MUA not to index the new mail because it thinks the mail is a dupe.
I'll attach copies of two messages with the same Message-ID.

Attachments (2)

1288071702.18372.setoy (2.7 KB) - added by sascha_silbe 10 years ago.
first message with Message-ID 042.bf41d6c41f7ade4f87f31c611eed147b@…
1291566985.12039.setoy (2.8 KB) - added by sascha_silbe 10 years ago.
second message with Message-ID 042.bf41d6c41f7ade4f87f31c611eed147b@…

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by sascha_silbe

first message with Message-ID 042.bf41d6c41f7ade4f87f31c611eed147b@…

Changed 10 years ago by sascha_silbe

second message with Message-ID 042.bf41d6c41f7ade4f87f31c611eed147b@…

comment:1 Changed 10 years ago by bernie

did you report it upstream? (haha)

aslso, why is this bug assigned to "silbe" rather than "sascha_silbe"?

comment:2 Changed 10 years ago by sascha_silbe

  • Owner changed from silbe to sascha_silbe
  • Status changed from new to assigned

Diagnosed and reported upstream; waiting for the upstream ticket to make it through moderation.

comment:3 Changed 10 years ago by sascha_silbe

Upstream ticket is FAST#3903.

comment:4 Changed 10 years ago by sascha_silbe

Fixed on bugs-devel, patch sent upstream (attached to FAST#3903, currently waiting for moderation).

comment:5 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.