Opened 10 years ago

Closed 10 years ago

#2509 closed defect (notsugar)

Measure-32 measures garbage on first start on XO-1.5

Reported by: carrott Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Measure Version: Unspecified
Severity: Unspecified Keywords:
Cc: silbe Distribution/OS: Dextrose
Bug Status: Unconfirmed

Description (last modified by carrott)

Measure-32 os os5dx2 shows garbage on the first start after bootup on an XO-1.5. Stopping and starting measure restores more normal operation. See screenshot for example of noise.

This does not occur on the XO-1.0 (also running os5dx2).

Attachments (2)

Screenshot of "Measure Activity".png (44.8 KB) - added by carrott 10 years ago.
measure with noise
org.laptop.MeasureActivity-1.log (5.1 KB) - added by RafaelOrtiz 10 years ago.
Complete log

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by carrott

measure with noise

comment:1 Changed 10 years ago by carrott

  • Description modified (diff)

Changed 10 years ago by RafaelOrtiz

Complete log

comment:2 Changed 10 years ago by RafaelOrtiz

this seems specific to the audio driver for the xo-1.5. diagnose what wasnt happening in previuos versions of Measure.


comment:3 follow-up: Changed 10 years ago by RafaelOrtiz

Lowering CAPTURE_GAIN to 40 seems like fixes the issue, the high gain can be measuring garbage at start.

comment:4 in reply to: ↑ 3 Changed 10 years ago by RafaelOrtiz

Replying to RafaelOrtiz:

Lowering CAPTURE_GAIN to 40 seems like fixes the issue, the high gain can be measuring garbage at start.

Not truth. still having the same issue. tested with various init confgutations.


comment:5 follow-up: Changed 10 years ago by RafaelOrtiz

if it's a hardware specific issue as a workaround we can set initial measured frecuency and amplitud. to lower vales.

comment:6 in reply to: ↑ 5 Changed 10 years ago by RafaelOrtiz

  • Cc silbe added

Replying to RafaelOrtiz:

if it's a hardware specific issue as a workaround we can set initial measured frecuency and amplitud. to lower vales.

Doesn't work either.

comment:7 Changed 10 years ago by carrott

This seems to be improved in os23. On ivy, it seems to work correctly all the time. On Tank, it seems to measure garbage on the first start after a reboot and then correctly on every subsequent start.

Ivy is a production xo 1.5. Tank is an XO 1.5 C2.

comment:8 Changed 10 years ago by RafaelOrtiz

  • Resolution set to notsugar
  • Status changed from new to closed

@carrot, thanks for testing, this is a hardware dependent problem, I'm going to close it here as not sugar, but should be tracked or filled at dev.laptop.org


Note: See TracTickets for help on using tickets.