Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2505 closed enhancement (fixed)

Feature: hide palette behavior

Reported by: sethwoodworth Owned by: walter
Priority: Normal Milestone: Unspecified
Component: Turtleart Version: Git as of bugdate
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Hide/show palette is visible and reacts with expected behavior.

The palette ribbon should expand and collapse based on a second click of the selector icon:

  1. User clicks on currently unselected palette icon (math)
  2. Palette appears
  3. User clicks on currently selected palette icon (math)
  4. Nothing happens (suggest: should disappear)

Attachments (1)

TurtleArt-104.xo (998.1 KB) - added by walter 10 years ago.
palette disappears (Sugar 0.86+ only)

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor
  • Status changed from new to accepted
  • Version changed from Unspecified to Git as of bugdate

I like this suggestion in part because it will allow me to eliminate the separate button for hiding the palette.

Changed 10 years ago by walter

palette disappears (Sugar 0.86+ only)

comment:2 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from accepted to closed

I am only fixing this for 0.86+ toolbars (in other cases, the selectors disappear, making restore awkward).

Note: See TracTickets for help on using tickets.