Opened 10 years ago

Closed 10 years ago

#2499 closed enhancement (fixed)

Browse should restore Back/Forward history portions to respective buttons

Reported by: greenfeld Owned by: lucian
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Ticket #2383 / 10437 lets us restore the last page a user was on while also saving the user's Browsing history.

However the user's entire browsing history ends up in the Back history button. Should we consider saving where we were to put the appropriate amount of history in both the Forward & Back history buttons?

The downside to this approach is that if the user clicks a new link, the entire past Forward history is lost. But this happens during normal usage without saving to the journal & resuming as well.

Tested on OLPC build 10.1.3 os353.

Change History (3)

comment:1 Changed 10 years ago by greenfeld

  • Summary changed from Browse should restore Back/Forward history and not just to Browse should restore Back/Forward history portions to respective buttons

comment:2 Changed 10 years ago by lucian

  • Status changed from new to accepted

This happens because currently Browse only remembers the history, but not the position in the history where the user last was.

This is fixed in the webkit branch, but I think it could also be implemented in master.

comment:3 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.