Opened 10 years ago

Closed 10 years ago

#2488 closed defect (fixed)

Cannot connect to adhoc network with name less than 8 characters

Reported by: carrott Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: untriaged Version: 0.88.x
Severity: Unspecified Keywords: dextrose
Cc: sridhar Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

meshbox.py and network.py attempt to recover an adhoc network's colours from the network's name but this code fails if the name is too short. Such networks just don't show up in the neighbourhood view.

See attached adhoc-name.patch for a fix. Even with this fix, it is likely that a pathological network name can still cause problems. I didn't perform any significant testing after I got my adhoc network to work.

File "/usr/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 1077, in _ap_props_changed_cb

self._add_ap_to_network(ap)

File "/usr/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 1054, in _add_ap_to_network

icon = WirelessNetworkView(ap)

File "/usr/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 93, in init

and self._name_encodes_colors():

File "/usr/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 151, in _name_encodes_colors

return self._name[-7] == '#' and self._name[-8] == ',' \

IndexError: string index out of range

Attachments (1)

adhoc-name.patch (1.3 KB) - added by carrott 10 years ago.
fix for short adhoc network names

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by carrott

fix for short adhoc network names

comment:1 Changed 10 years ago by carrott

This also effects au852-4 on XO-1.5 but does not effect os860 on XO-1.0

comment:2 Changed 10 years ago by sridhar

  • Cc sridhar added

comment:3 Changed 10 years ago by carrott

  • Resolution set to fixed
  • Status changed from new to closed

Seems to be fixed on os23.

Note: See TracTickets for help on using tickets.