Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#2482 closed defect (obsolete)

no palette for Journal list view entries, broken details view

Reported by: sascha_silbe Owned by:
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS:
Bug Status: New

Description

Sometimes the Palette for Journal list view entries doesn't appear and the details view is broken. There's a series of Tracebacks like the following in shell.log:

dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.10 was not provided by any .service files
Traceback (most recent call last):
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/palettewindow.py", line 933, in __motion_notify_event_cb
    self.notify_mouse_enter()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/palettewindow.py", line 629, in notify_mouse_enter
    self._ensure_palette_exists()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/sugar/graphics/palettewindow.py", line 624, in _ensure_palette_exists
    palette = self.parent.create_palette()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/journal/listview.py", line 602, in create_palette
    palette = ObjectPalette(metadata, detail=True)
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/journal/palettes.py", line 103, in __init__
    friends_menu = FriendsMenu()
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/journal/palettes.py", line 169, in __init__
    if filetransfer.file_transfer_available():
  File "/home/sascha.silbe/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/model/filetransfer.py", line 341, in file_transfer_available
    properties = properties_iface.GetAll(CONNECTION_INTERFACE_REQUESTS)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 630, in call_blocking
    message, timeout)

I have no idea how to trigger this reliably. So far, it happened only while being connected to a Jabber server. Switching to Salut (even though that's broken inside chroots) "fixed" it, as did restarting Sugar (with the server setting back to jabber.sugarlabs.org).

Filing against sugar because filetransfer.file_transfer_available() should just return False if something is broken (and probably log the exception).

Change History (2)

comment:1 Changed 8 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

Years old, not reproducable.

comment:2 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.