Opened 11 years ago

Closed 10 years ago

#2461 closed enhancement (fixed)

Turtle Art sharing

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

At this stage just a discussion on sharing in TA

Currently the following are shared:
turtle absolute heading
turtle relative position
pen trails

Not shared:
fill
absolute position
print
show text
show multimedia
blocks
fill screen

It takes up to 13 seconds for changes to appear with 2 sharing a session.
Blocks can be shared with Write and "send to" but not Chat #846 or speak/chat

Is collaborative authoring really supported? What is the best sharing workflow if you are not in the same place? TA & chat? chat/speak? Write?

Without causing software bloat, should print output be shared? show text? Should the print output be copyable? (hence a simple block and text sharing method)

All questions.

Change History (3)

comment:1 Changed 10 years ago by walter

In the next release, show text and show pictures (but not sound or movies yet) will be shared. Fill should make the cut as well.
Fill screen I think not, since it covers up everyone's drawings.
Hadn't thought about print.
Absolute position??? setxy is shared, but do you mean moving the turtle with the mouse?

Re copyable output from print, interesting. We could add a Python block that outputs to the clipboard. Maybe that is sufficient?

comment:2 Changed 10 years ago by walter

in v106, sharing of fill, bitmaps, and text are supported. Closing this ticket and opening a separate on re the clipboard.

comment:3 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.