Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#2456 closed defect (fixed)

Copying Bundle to storage medium immediately deletes it again

Reported by: sascha_silbe Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone:
Component: journal Version: 0.90.x
Severity: Major Keywords:
Cc: Distribution/OS:
Bug Status: Assigned

Description

How to reproduce:

  1. Choose a Bundle (Activity or Content) from the Journal
  2. Drag it to a mount point icon in the volume tool bar
  3. Switch to the mount point

Expected results:
The Journal shows the contents of the storage medium, including the copied bundle.

Actual results:
The Journal shows the contents of the storage medium, but the bundle is missing.

This is because the bundle is copied, but deleted right afterwards:

1287311330.770745 DEBUG root: model.write '' '/home/sascha.silbe/.sugar/default/data/9bf86117-19eb-473a-bd61-f4f992414bea-54538fd9-2b37-4d9a-8756-83b0e3962de3_fPiMzB.xo' True
[...]
1287311330.795387 DEBUG root: get_file asked for file with path '/media/tmp/File irc-5.xo from http___activities.sugarlabs.org_en-US_sugar_downloads_file_25975_xpi_irc-5.xo..xo'
1287311330.795786 DEBUG root: TempFilePath created '/media/tmp/File irc-5.xo from http___activities.sugarlabs.org_en-US_sugar_downloads_file_25975_xpi_irc-5.xo..xo'
[...]
1287311330.800654 DEBUG root: _check_for_bundle bundle already installed
1287311330.801382 DEBUG root: TempFilePath deleted '/media/tmp/File irc-5.xo from http___activities.sugarlabs.org_en-US_sugar_downloads_file_25975_xpi_irc-5.xo..xo'

Change History (2)

comment:1 Changed 10 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by a2e1f09 / ddedea8.

comment:2 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.