Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2451 closed defect (fixed)

Installed activities do not automatically show up in favorites view

Reported by: bernie Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: untriaged Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This may seem minor, but it's a usability barrier for new users. Here's how to reproduce the bug:

  1. Download an activity from Browse
  2. Go to the Journal
  3. Find the activity and click on it to make it install and run
  4. Now go to the home view
  5. Where is the activity?

The answer to 5 is: it is hidden in the list view. Fine, but it takes users a lot of time to figure this out. Some of them keep clicking on the activity bundle in the journal, or even download it again.

If a user just installed an activity, it means they're going to use it. It makes sense to automatically mark it as favorite.

Change History (4)

comment:1 Changed 10 years ago by walter

Which version of Sugar is this? The expected behavior (and what see consistently) is:

(1) Download an activity with Browse.
(2) It will appear in the Home View.

I cannot reproduce your bug.

comment:2 Changed 10 years ago by bernie

  • Resolution set to fixed
  • Status changed from new to closed

Sorry, invalid report. Sugar already behaves correctly when installing new activities. I was fooled by an already installed activity which was not favorite.

comment:3 follow-up: Changed 10 years ago by walter

'I was fooled"

Hopefully we can make some headway on eliminating the List View for 0.92. As I understand it, the plan of record is to use the ⭐ in the Journal.

comment:4 in reply to: ↑ 3 Changed 10 years ago by bernie

Replying to walter:

Hopefully we can make some headway on eliminating the List View for 0.92. As I understand it, the plan of record is to use the ⭐ in the Journal.

Seems like a very good idea, if we could add an "activities" entry in the filter-by drop down list on the toolbar.

For consistency, we should also account installed activities as used space in the journal and report their size correctly in the "sort by size" view.

Note: See TracTickets for help on using tickets.