Opened 11 years ago

Closed 8 years ago

Last modified 8 years ago

#2439 closed defect (fixed)

Grab key moves full screen windows

Reported by: tonyforster Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.90.x
Severity: Unspecified Keywords: olpc-0.90
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

The grab key, second from left bottom row moves windows that are not meant to move. It really messes up the journal.
os 17 xo1

Attachments (2)

Screenshot of "Sliderule Activity" and home.png (60.3 KB) - added by tonyforster 11 years ago.
Screenshot of "Journal".png (57.0 KB) - added by tonyforster 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by tonyforster

Changed 11 years ago by tonyforster

comment:1 Changed 10 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from Unspecified by Release Team to 0.92

comment:2 follow-up: Changed 10 years ago by sascha_silbe

Sounds like we're missing some X property that tells the window manager we don't want anyone to mess around with the window. A call to gtk.Window.set_resizable() might do the trick.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 10 years ago by erikos

Replying to sascha_silbe:

Sounds like we're missing some X property that tells the window manager we don't want anyone to mess around with the window. A call to gtk.Window.set_resizable() might do the trick.

I actually thought we should handle it by the gconf config like - I tried disabling a few but did not picked the right one so far.

comment:4 in reply to: ↑ 3 Changed 10 years ago by sascha_silbe

Replying to erikos:

I actually thought we should handle it by the gconf config like - I tried disabling a few but did not picked the right one so far.

But that would affect all windows then, including those of non-Sugar applications, wouldn't it?

comment:5 Changed 10 years ago by sascha_silbe

Part of the issue is that as of 7654252 we don't use X11 full screen mode anymore, but rather just hide the toolbar.

One might also argue that this is a feature, not a bug. It allows users to work around broken activities that don't adapt to arbitrary screen dimensions properly.

comment:6 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed

Seems fixed from d.l.o bug.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.92 deleted

Milestone 0.92 deleted

Note: See TracTickets for help on using tickets.