Opened 9 years ago

Closed 8 years ago

#2431 closed defect (duplicate)

os15 browse crashes on yes/no dialog

Reported by: tonyforster Owned by: lucian
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: 0.90.x
Severity: Unspecified Keywords: olpc-0.90
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by tonyforster)

XO1 os15
browse hangs on yes/no dialog
another log at #2291 (sorry)
the error has something to do with corrupt double linked lists

Attachments (2)

Text clipping2ndmsgbox.txt (4.3 KB) - added by tonyforster 9 years ago.
crash on dialog box
Screenshot of "Browse Activity"crashed.png (131.3 KB) - added by tonyforster 9 years ago.

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by tonyforster

crash on dialog box

comment:1 Changed 9 years ago by tonyforster

  • Description modified (diff)
  • Keywords olpc-0.90 added

comment:2 Changed 9 years ago by erikos

  • Resolution set to duplicate
  • Status changed from new to closed

According to your logs a duplicate of #2406. We will have a new release by next week.

comment:3 Changed 9 years ago by tonyforster

Is it a duplicate? #2406 is about ints and floats, nothing in Text clipping2ndmsgbox.txt Download (4.3 KB) about int and float

comment:4 Changed 9 years ago by erikos

  • Resolution duplicate deleted
  • Status changed from closed to reopened

ony, sorry I was confused by the log you pasted after your comment. Can you give steps to reproduce for this one? What do you mean with yes/no dialog?

comment:5 Changed 9 years ago by tonyforster

Yes, that log confused me too, it wasnt the float/int that crashed the browser. I should have said cancel/ok dialog box (I get this confirmation dialog when I am using webmail and delete a mail).

It doesnt crash every time though.

Changed 9 years ago by tonyforster

comment:6 Changed 9 years ago by tonyforster

Go delete mail, cancel, delete mail, cancel about 5 or 10 times to get a crash
screenshot of browse in crashed state attached.

comment:7 Changed 8 years ago by RafaelOrtiz

Can you test with newer versions of browse, what version did you test with ?.

comment:8 Changed 8 years ago by RafaelOrtiz

Also this sounds like a dup of #2615, more relevant information there.

comment:9 Changed 8 years ago by tonyforster

Hi, logged this error 7 months ago with the then current version of browse. Observed problem has changed since then but still unsatisfactory with some sugar versions as #2615 describes. I am now running Browse115 on OS373pyg and getting OK results but even that gives problems on some websites. For example clicking 'done' after uploading photo to blogger closes the activity.

Suggest this ticket be closed and issues with popups, dialogs and multiple windows be tracked in #2615

comment:10 Changed 8 years ago by RafaelOrtiz

  • Resolution set to duplicate
  • Status changed from reopened to closed

Thanks Tony, closing as dup of #2615

Note: See TracTickets for help on using tickets.