Opened 11 years ago

Closed 10 years ago

#2421 closed defect (notsugar)

After XO-1 sleep, there is a 3-4min delay before wireless access points appear

Reported by: garycmartin Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: olpc-0.90
Cc: tonyforster, bernie, dsd Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

In F14 0.90 XO-1 test builds (os15.img) there is a 3-4 min delay before the wireless access points re-appear in neighbourhood after coming out of sleep (after closing the lid, or pressing power once and waiting). As a result, when the XO-1 wakes up, it connects to Mesh 1 as the default wireless access point appears several min later.

This could be a nasty network effect for a school using default access point/s to manage their wireless spectrum load.

Change History (7)

comment:1 Changed 11 years ago by garycmartin

On further testing it appears that after wake up, the cycle through the three mesh networks seems to be blocking the addition of any access points. The access points appear immediately after the mesh check cycle is complete and having joined a mesh.

comment:2 Changed 11 years ago by tonyforster

This error, generated by opening and shutting the lid might be relevant
1286593557.410436 ERROR root: Error getting the active access point: org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

comment:3 Changed 11 years ago by tonyforster

  • Cc tonyforster added

comment:4 Changed 11 years ago by bernie

We had this bug in Dextrose too. We fixed it (and others) by disabling the mesh on the XO-1.

I recommend giving up on the mesh. It sounds like a good idea, but in 3 years we could not get it to work reliably and we don't even have access to the libertas firmware source to fix it.

The standard ad-hoc networking may not sound as cool, but it works well and covers the famous "under a tree" use-case.

comment:5 Changed 11 years ago by bernie

  • Cc bernie added

comment:6 Changed 10 years ago by dsd

  • Cc dsd added

Can't reproduce on 11.2.0 build 18 (Sugar-0.92.1). The APs appear quickly after resume, and the connection is reestablished.

comment:7 Changed 10 years ago by dsd

  • Resolution set to notsugar
  • Status changed from new to closed

This has a full diagnosis at http://dev.laptop.org/ticket/10694 and has been tracked down to a kernel bug, fixed in more recent kernels. As this is unrelated to SugarLabs I'll close this ticket and we can use the OLPC one for tracking inclusion into OLPC builds.

Note: See TracTickets for help on using tickets.