Opened 11 years ago

Closed 10 years ago

#2408 closed defect (fixed)

Restore to a different XO

Reported by: sridhar Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Restore Version: Unspecified
Severity: Unspecified Keywords:
Cc: sridhar Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Comment from OLPC-NZ testing team:

Tried to restore the same journal file on another XO but it doesn't let you (deliberate we think)

We are interested in using Backup/Restore to migrate a child from one XO to another. This may happen because (for example):

  • the child's XO has broken and they have received a new one
  • the child is migrating to a new model XO (e.g. from an XO-1 to an XO-1.5)

This means that we want Restore to be able to restore to any XO.

Change History (5)

comment:1 Changed 10 years ago by sascha_silbe

  • Owner changed from silbe to sascha_silbe
  • Status changed from new to assigned

comment:2 Changed 10 years ago by sascha_silbe

This should work just fine. There's no code in Restore to check who or what has created the bundle. What exactly happens if you try? Please include the full error message and / or the log file if applicable.

comment:3 Changed 10 years ago by sridhar

  • Resolution set to duplicate
  • Status changed from assigned to closed

This works in Restore 4

comment:4 Changed 10 years ago by sridhar

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:5 Changed 10 years ago by sridhar

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.