Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#2404 closed defect (fixed)

OS15 0.90 Browse crashes launching second instance

Reported by: tonyforster Owned by: lucian
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: 0.90.x
Severity: Unspecified Keywords: olpc-0.90
Cc: m_anish, tomeu Distribution/OS: Unspecified
Bug Status: Assigned

Description

Tried to launch a second instance of Browse (because tabbed browsing is not supported, a regression on OS373pyg)

Message: pygobject_register_sinkfunc is deprecated (HippoCanvasBox)
returning /home/olpc/.sugar/default/org.laptop.WebActivity/data/gecko/prefs.js for key NS_APP_PREFS_50_FILE
process 2079: Array or variant type requires that type string be written, but end_dict_entry was written.
The overall signature expected here was 'a{ss}' and we are on byte 3 of that signature.

D-Bus not built with -rdynamic so unable to print a backtrace

Terminated by signal 6, pid 2079 data (None, <open file '<fdopen>', mode 'w' at 0x9424d88>, '5d23c036d6d46c4ea896ffaff0df5a363e013375')

Change History (12)

comment:1 Changed 11 years ago by tonyforster

  • Keywords olpc-0.90 added

comment:2 follow-up: Changed 11 years ago by tonyforster

I had said that tabs are not supported. Though ctrl t will not create a tab, some websites will, closing one tab exits browse.

comment:3 follow-up: Changed 11 years ago by erikos

  • Cc m_anish added

Reproduced on latest Soas build as well.

Yes, the tabs are not supported. The feature is dependent on a specific cairo version. I have cc'ed m_anish he should know more about it. And closing the last tab exists browse I think is a known bug (should be here in the tracker).

comment:4 Changed 11 years ago by erikos

  • Milestone changed from Unspecified by Release Team to 0.90

comment:5 in reply to: ↑ 2 Changed 11 years ago by erikos

  • Cc tomeu added

Tomeu can you check that one on F14 quickly, too?

comment:6 Changed 11 years ago by erikos

Verified by Tomeu in F14 and from me in jhbuild. Is a regression, Tomeu is working on it.

comment:7 in reply to: ↑ 3 Changed 11 years ago by m_anish

Replying to erikos:

Reproduced on latest Soas build as well.

Yes, the tabs are not supported. The feature is dependent on a specific cairo version. I have cc'ed m_anish he should know more about it. And closing the last tab exists browse I think is a known bug (should be here in the tracker).

AFAIK, browse won't enable the multiple tabs feature if it detects Cairo version 1.8.10 or later (commit). This was due to a possible bug in Cairo. However, this seems to suggest that the problem is somewhere else.

comment:8 follow-up: Changed 11 years ago by erikos

|test case|

  • open Browse
  • open a second Browse instance

---> second instance won't start

comment:9 Changed 11 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Resolution set to fixed
  • Status changed from new to closed

comment:11 in reply to: ↑ 8 Changed 11 years ago by sascha_silbe

Replying to erikos:

|test case|

  • open Browse
  • open a second Browse instance

---> second instance won't start

Shouldn't this read "second instance does start"?

Also I'm a bit confused about the ticket summary and the component saying Browse, but the fix being committed to sugar-toolkit. Reading the commit didn't help as the description explains we're "adapting to API changes" without giving any details (which API did change in what way and who changed it?). The code changes don't make it any clearer why starting a second Browse instance would break without it, either.

comment:12 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.