Opened 11 years ago

Closed 8 years ago

#2398 closed enhancement (obsolete)

svg should be included in mime.GENERIC_IMAGE_TYPE

Reported by: walter Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The attach patch should do the trick...

(Should there be a separate component for sugar-base?)

Attachments (1)

0001-add-image-svg-xml-to-GENERIC_TYPE_IMAGE.patch (727 bytes) - added by walter 11 years ago.
adds image/svg+xml to mime.GENERIC_IMAGE_TYPE

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by walter

adds image/svg+xml to mime.GENERIC_IMAGE_TYPE

comment:1 Changed 10 years ago by sascha_silbe

  • Cc erikos added
  • Owner changed from tomeu to sascha_silbe
  • Status changed from new to assigned

Patch looks good to me, thanks!
Simon, any objection? This is the first vector image format for GENERIC_TYPE_IMAGE, but I don't see a compelling reason to allow only bitmap formats. If any activity can't sensibly cope with SVG (even by just converting it), we should rather work on #2400 so activities can tell the Journal about that inability.

comment:2 Changed 8 years ago by godiard

  • Resolution set to obsolete
  • Status changed from assigned to closed

The svg format is already included now, because we include all the formats supported by GtkPixbufs. (sugar-toolkit-gtk3)

Note: See TracTickets for help on using tickets.