Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#2394 closed defect (fixed)

Terminal issues in F14

Reported by: erikos Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Terminal Version: Unspecified
Severity: Unspecified Keywords: olpc-0.90
Cc: Distribution/OS: Unspecified
Bug Status: Assigned

Description

In latest soas builds I can not scroll when using less: "Warning Terminal is not fully functional".

On the XO builds I could not edit files with Vi neither, which works in Soas ok.

There was a new version of VTE in updates-testing (0.26.0-1) but that one did not fix that issue (tested in soas).

Change History (10)

comment:1 Changed 11 years ago by sascha_silbe

Sounds like $TERM isn't set properly or the terminfo database is broken. What does

echo $TERM

say?

If it's non-empty, the tack tool might be useful for debugging (I've never tried it before, though).

comment:2 Changed 11 years ago by erikos

Sascha, thanks for your quick feedback.

TERM is set to dumb (setting it to xterm fixes it). Looks like behavior in vte has changed.

https://bugs.launchpad.net/terminator/+bug/621606

I have not found the exact message for the change - but I guess like others we just have to hardcode it.

comment:3 Changed 11 years ago by erikos

  • Keywords olpc-0.90 added

comment:5 Changed 11 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Owner changed from sayamindu to erikos
  • Status changed from new to assigned

comment:6 Changed 11 years ago by erikos

  • Milestone changed from Unspecified by Release Team to 0.90

We have an upstream solution, thanks to Tomeu: https://bugzilla.gnome.org/show_bug.cgi?id=631589#c13 Yipee!

comment:7 Changed 11 years ago by tomeu

What should we do with this ticket? I'd probably close it as notsugar and open tickets in our downstreams so they patch their packages or ping the vte maintainers to make a new stable release.

comment:9 Changed 11 years ago by erikos

  • Resolution set to fixed
  • Status changed from assigned to closed

Has been fixed in vte 2.26.1, verified in recent builds.

comment:10 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.