Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2358 closed defect (fixed)

setxy should honor pendown

Reported by: DanielAjoy Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Major Keywords:
Cc: tonyforster Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

setxy is not drawing lines as it should when the pen is down. it just goes to the x,y position.

This behaviour is not like any Logo I know.

TurtleArt version 98

Attachments (1)

tortugarte-triangulos.png (51.9 KB) - added by DanielAjoy 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by DanielAjoy

comment:1 Changed 11 years ago by walter

FWIW, this behavior hasn't changed since TA v1. It is easy enough to change if there is consensus.

comment:2 Changed 11 years ago by DanielAjoy

I would argue that it is important. Eg. to be able to draw figures like #55 or #27 or #69 (to plot curves)

http://neoparaiso.com/logo/ejercicios-de-geometria.html

comment:3 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Will be included in v99. (Note that old projects will still get the old behavior.)

comment:4 Changed 11 years ago by tonyforster

  • Cc tonyforster added

comment:5 Changed 11 years ago by tonyforster

I have no problem with the change, I kind of got used to it the way it was but I think the change is for the better

Note: See TracTickets for help on using tickets.