Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#2347 closed defect (obsolete)

sugar-ui-check is not up-to-date

Reported by: erikos Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: sascha_silbe Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

https://bugzilla.redhat.com/show_bug.cgi?id=635387

sugar-ui-check:31:<module>:ImportError: cannot import name
get_sugar_window_type

Traceback (most recent call last):
  File "/usr/bin/sugar-ui-check", line 31, in <module>
    from jarabe.model.shell import get_sugar_window_type
ImportError: cannot import name get_sugar_window_type

Change History (10)

comment:1 Changed 10 years ago by tomeu

Regardless of this bug, I don't see any value in this being shipped by distros.

comment:2 follow-up: Changed 10 years ago by erikos

Right, and as it is outdated and not used by anyone, maybe we should just get rid of it? Or at least put it in sugar-tools?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 10 years ago by tomeu

  • Cc sascha_silbe added

Replying to erikos:

Right, and as it is outdated and not used by anyone, maybe we should just get rid of it? Or at least put it in sugar-tools?

Not sure, I think the build bots used to use it. Maybe Sascha knows?

comment:4 in reply to: ↑ 3 Changed 10 years ago by sascha_silbe

Replying to tomeu:

Replying to erikos:

Right, and as it is outdated and not used by anyone, maybe we should just get rid of it? Or at least put it in sugar-tools?

Not sure, I think the build bots used to use it. Maybe Sascha knows?

Never heard of it before. Unless it's referenced in the build system (i.e. by "make check") the build slaves won't use it.

comment:5 follow-up: Changed 10 years ago by erikos

[erikos@pennylane sugar-jhbuild]$ grep -inr sugar-ui-check scripts/
scripts/check.py:57: sugar-ui-check?, standard_output=True, standard_error=True,

comment:6 in reply to: ↑ 5 ; follow-up: Changed 10 years ago by sascha_silbe

Replying to erikos:

[erikos@pennylane sugar-jhbuild]$ grep -inr sugar-ui-check scripts/
scripts/check.py:57: sugar-ui-check?, standard_output=True, standard_error=True,

scripts/* isn't used anywhere. I should probably just remove the entire directory.

comment:7 in reply to: ↑ 6 Changed 10 years ago by erikos

Replying to sascha_silbe:

Replying to erikos:

[erikos@pennylane sugar-jhbuild]$ grep -inr sugar-ui-check scripts/
scripts/check.py:57: sugar-ui-check?, standard_output=True, standard_error=True,

scripts/* isn't used anywhere. I should probably just remove the entire directory.

Works for me.

comment:8 Changed 10 years ago by sascha_silbe

scripts/*.py is gone now, so we're not referencing sugar-ui-check anywhere anymore AFAICT. +1 for pruning it.

comment:9 Changed 8 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

This has been killed.

comment:10 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.