Opened 9 years ago

Closed 6 years ago

#2320 closed defect (notsugar)

"./setup build" traceback, and failing to build activity locale from po

Reported by: garycmartin Owned by: bernie
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Dextrose Version: Unspecified
Severity: Critical Keywords: Soas, Dextrose
Cc: Distribution/OS: Fedora
Bug Status: New

Description

Tested in Fedora F13 with the sugar desktop packages installed (Mirabelle), F14 Soas nightly build (Mango Lassi), and a Dextrose os373pyg XO-1 build. When trying to run ./setup build in an Activity directory to generate the locale from the po, the attached traceback is generated. Downloading/installing .xo bundles (via Browse or clicking on a .xo bundle in the Journal) is also not generating any locale files.

Testing this same process in an 802 or 852 build, ./setup build, correctly generates the locale files.

Is this a known change in behaviour in Sugar for bundlebuilder, or is it an issue of some missing package on the distro side?

Attachments (1)

setup_build_traceback.txt (957 bytes) - added by garycmartin 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by garycmartin

comment:1 Changed 9 years ago by alsroot

looks like msgfmt from gettext package was not installed

comment:2 follow-up: Changed 9 years ago by bernie

  • Bug Status changed from Unconfirmed to Needinfo

Please try:

sudo yum install gettext

comment:3 in reply to: ↑ 2 Changed 9 years ago by garycmartin

  • Bug Status changed from Needinfo to New

Replying to bernie:

Please try:

sudo yum install gettext

Yes this resolves the issue, locale directories and the .mo files are building again. Tested the fix in Soas and Dextrose. How do we make sure this dependancy gets included?

comment:4 Changed 8 years ago by sascha_silbe

  • Component changed from untriaged to Dextrose
  • Owner set to bernie

comment:5 Changed 6 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed

Dextrose is not tracked here anymore.

Note: See TracTickets for help on using tickets.