Opened 10 years ago

Closed 10 years ago

#2315 closed defect (notsugar)

Physics crash on shutdown

Reported by: carrott Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Physics Version: SoaS 3 (Mirabelle)
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I started up sugar on a stick Mirabelle to test out a new branch of USB sticks. I fooled around with physics for a bit, stopped phyics and tried to shut it down. It refused to shutdown and acted rather strangely. Looking in the logs, I found mention of an abort.

I have the abort and coredump, and attached is a backtrace from the core. If you want the core, I can attach too (it's about 4.5MB compressed).

To get gdb I had to transfer the sugar on a stick into virtualbox using vboxmanage as my laptop's wireless is not supported. During the gdb and debuginfo installation process the guest locked up with 100% cpu usage in the host. I have a snapshot taken during this lockup time. On restarting the guest, I find that there is filesystem corruption. I cannot be 100% sure that the corruption stems from the crash and restart (sugar on a stick appears to be a linux filesystem on a vfat filesystem??) or from corruption on the usb stick (which might explain why it was behaving strangely in the first place).

Attachments (1)

backtrace.txt (54.2 KB) - added by carrott 10 years ago.
backtrace from gdb

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by carrott

backtrace from gdb

comment:1 Changed 10 years ago by garycmartin

  • Component changed from untriaged to Physics
  • Owner set to garycmartin

comment:2 Changed 10 years ago by garycmartin

  • Resolution set to notsugar
  • Status changed from new to closed

Sorry, haven't been able to pick anything useful out of the backtrace. Closing as 'not sugar', but do reopen if you can reproduce it. Could well have been a crash due to the USB stick corruption as you mention.

Note: See TracTickets for help on using tickets.