Opened 10 years ago

Closed 7 years ago

#2295 closed defect (incomplete)

Sugar 0.88 [Dextrose] not reporting all favourite connections to NetworkManager at startup

Reported by: fmiceli Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.88.x
Severity: Minor Keywords:
Cc: Distribution/OS: Dextrose
Bug Status: Unconfirmed

Description

While making mods to NM autoconnection feature I've come across a weird behaviour from the favourites connections (/home/olpc/.sugar/connections.cfg) reported to NetworkManager at startup.

What I've seen is that -only at startup- just one connection gets reported to real_get_best_autoconnection (a function within nm-device-wifi.c), thus being this one the one that gets choosen by NM (if there's an AP that matches it).

By debuging NM I found out that only one favourite connection was reported (from several in connections.cfg) and all APs where seen. This behaviour doesn't repeat itserf if the autoconnection feature gets executed after this first time.

I don't know if it only happens with Dextrose because I haven't tested it on other distributions.

Change History (3)

comment:1 Changed 10 years ago by sascha_silbe

  • Component changed from untriaged to sugar
  • Keywords NetworkManager autoconnection favorites removed
  • Owner set to tomeu
  • Severity changed from Unspecified to Minor

comment:2 Changed 10 years ago by tomeu

Hi Franco, have you found the place in Sugar that provides that single connection to NM?

comment:3 Changed 7 years ago by dnarvaez

  • Resolution set to incomplete
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.