Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#2292 closed enhancement (incomplete)

Enhance Sugar to support multiple users

Reported by: ChristophD Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: design Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The 300,000 XOs that Peru will be distributing in the next phase of its "Una laptop por nino" program will be shared between multiple pupils (article). Currently Sugar is very much designed to run on a machine that's owned by a single user. Hence I think it makes sense to start a discussion about how Sugar should be enhanced to support such a usage-scenario.

Change History (4)

comment:1 Changed 9 years ago by mikus

Two years ago I experimented with having two simultaneous sessions open:

  startx /usr/bin/olpc-session -- :1 -fp built-ins -wr

It worked - though sugar was not entirely happy.

comment:2 Changed 9 years ago by walter

SoaS would work in this scenario. Perhaps we can use it as the strawman to compare with other proposals.

comment:3 Changed 8 years ago by sascha_silbe

  • Component changed from untriaged to design
  • Keywords users login Journal removed
  • Resolution set to incomplete
  • Status changed from new to closed

I'm closing this bug because it's too broad in scope and it isn't even clear we should change anything in Sugar itself to support this scenario. See also the discussion on sugar-devel.

comment:4 Changed 8 years ago by christophd

Personally I still think this is a big issue since I simply can't imagine how things work in Peru at the moment given that up to 10 pupils are sharing a single XO. At the same time I do understand that without local input and a better first-hand description of the use cases working on this issues isn't really feasible.

Note: See TracTickets for help on using tickets.