Opened 10 years ago

Closed 7 years ago

#2278 closed defect (fixed)

sugar-emulator: keyring is locked at startup

Reported by: tomeu Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

A dialog asking for the user password appears when starting up sugar-emulator. Not sure there's anything we can do in Sugar about it.

Change History (7)

comment:1 follow-up: Changed 10 years ago by bernie

What's causing it? the nm client?

comment:2 in reply to: ↑ 1 Changed 10 years ago by tomeu

Replying to bernie:

What's causing it? the nm client?

mission control (if configured so)

comment:3 Changed 10 years ago by sascha_silbe

Comment from jfruitet (I rejected the submission because Jean accidently modified the description instead of leaving a comment):

This bug happens with Fedora-14-i686-Live-SoaS.iso Seams to be the same bug that  https://bugzilla.redhat.com/
show_bug.cgi?id=649013

When you first boot Fedora 14 SoaS, after entering your name, it pops up the
main 'desktop' with a gnome-keyring window over the top asking for a password
for the default keyring. If you enter a password, the window comes right back
up again. You can never get past it by entering a password; you have to cancel
out of it. I didn't check what are the consequences of cancelling out of the
window (I'd guess passwords aren't stored in a keyring and you have to enter
them over and over again).

This isn't a gnome-keyring bug per se, I don't think, as it doesn't behave this
way on Desktop or LXDE spins; it's something to do with the Sugar environment
configuration or the SoaS spin configuration.

Since that password is asked when you reboot the system but is not well registered, you can't never access to
Sugar again.

comment:4 follow-up: Changed 9 years ago by alsroot

An option might be:

  • add param-password option to accounts.cfg file (MC doesn't do that if it uses gnome-keyring even if sugar passed password while account registering);
  • avoid using gnome-keyring at all by having fake dbus service files.

http://git.sugarlabs.org/sdk/sugar/commit/d0f89b1697f46c5c4f77a07403b45525e9dc0bd0

comment:5 Changed 9 years ago by alsroot

  • Cc alsroot added

comment:6 in reply to: ↑ 4 Changed 9 years ago by alsroot

Replying to alsroot:

An option might be:

  • add param-password option to accounts.cfg file (MC doesn't do that if it uses gnome-keyring even if sugar passed password while account registering);
  • avoid using gnome-keyring at all by having fake dbus service files.

http://git.sugarlabs.org/sdk/sugar/commit/d0f89b1697f46c5c4f77a07403b45525e9dc0bd0

Finally, I didn't get it running on Fedora-16 environment.
Will provide custom telepathy-mission-control via Sweets, built without gnome-keyring support.

comment:7 Changed 7 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed

sugar-emulator is dead, fixed in sugar-runner

Note: See TracTickets for help on using tickets.