Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2261 closed defect (fixed)

Record os373pyg has #2041 bug

Reported by: mavrothal Owned by: m_anish
Priority: High Milestone: Unspecified
Component: Dextrose Version: 0.88.x
Severity: Unspecified Keywords: Record activity
Cc: bernie, dsd, smparrish Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

os373pyg/XO-1.5
if you record a clip, play it back, remove it and try to record nother one, Record activity crashes. This is a dup of #2041 and olpc #10239
It was fixed in http://dev.laptop.org/ticket/10239

Change History (8)

comment:1 Changed 9 years ago by mavrothal

BTW this issue was laso reported as #1984

BTW2 Record-86 on os373pyg does not have this bug but has #2042

comment:2 Changed 9 years ago by bernie

  • Owner changed from bernie to m_anish
  • Status changed from new to assigned

Anish, could you please include the latest Record bundle in Dextrose?

comment:3 follow-up: Changed 9 years ago by bernie

Ping? Would you like me to do it?

comment:4 in reply to: ↑ 3 Changed 9 years ago by m_anish

Replying to bernie:

Ping? Would you like me to do it?

That would be great. Here's the link:
http://people.sugarlabs.org/~anish/Record-87.xo

comment:5 Changed 9 years ago by m_anish

  • Cc bernie added

This commit makes the change so that the latest os images will have the ui-fixes in Record rebased over mainline/record-86.

Don't know if this ticket should be closed yet.

comment:6 follow-up: Changed 9 years ago by smparrish

Bernie, since we are using http://people.sugarlabs.org/~anish/Record-87.xo in the Dextrose2 builds now do we need to keep this open?

comment:7 in reply to: ↑ 6 Changed 9 years ago by bernie

  • Cc dsd added
  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to smparrish:

Bernie, since we are using http://people.sugarlabs.org/~anish/Record-87.xo in the Dextrose2 builds now do we need to keep this open?

We can consider this fixed for Dextrose, thus closing this bug.

However, upstream Record needs to integrate a fix for the UI layout for different resolutions and font sizes. It currently works only on the XO with Sugar 0.84. m_anish's current fix isn't acceptable for upstream. The proposed clean solution consists in be rewriting Record's GUI using a different approach.

Daniel, I assume that Record is now also broken in your F14 builds. Are you perhaps planning to work on the UI rewrite? If not, could you indicate how it should be done, along with an effort estimate?

comment:8 Changed 9 years ago by smparrish

  • Cc smparrish added
Note: See TracTickets for help on using tickets.