Opened 10 years ago

Closed 10 years ago

#2242 closed defect (fixed)

Ctrl+Q doesn't Stop

Reported by: virtusanqa Owned by: rwh
Priority: Normal Milestone: Unspecified
Component: Calculate Version: 0.84.x
Severity: Minor Keywords:
Cc: kushan.athukorala@… Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Description
Quit the activity shortcut "Ctrl"+"Q" not functioning in Calculator & Etoys Applications.

Steps to Recreate

"Ctrl"+"Q" not functioning in Calculator

  1. Power on OLPC
  2. Wait for the activity ring (Desktop).
  3. Start Calculator.
  4. Press the keys Ctrl+Q
  5. Check the screen.

"Ctrl"+"Q" not functioning in Etoys

  1. Power on OLPC
  2. Wait for the activity ring (Desktop).
  3. Start Etoys.
  4. Press the keys Ctrl+Q
  5. Check the screen.

Expected Result
Applications should quit

Actual Result
Nothing happened

Test Environment
OS: Sugar and GNOME (Dual boot)
Machine Type: XO 1.5
Build: OS 851
Firmware: Q3A50

Change History (5)

comment:1 Changed 10 years ago by sascha_silbe

  • Component changed from untriaged to Calculate
  • Keywords Quit the activity removed
  • Owner set to rwh
  • Severity changed from Major to Minor
  • Summary changed from Quit the activity shortcut Ctrl+Q not functioning in Calculator & Etoys to Ctrl+Q doesn't Stop

virtusanqa, thanks for reporting these bugs!
In the future, please open a separate ticket for each bug, i.e. each activity. The fixes need to be done in each broken activity, so we need to one ticket each to track the progress.
I have opened #2253 for you to handle the Etoys part and assigned this one to Calculate.

comment:2 Changed 10 years ago by sascha_silbe

@rwh: This is probably caused by the custom keypress handler (keypress_cb). It returns True for unhandled, aborting event handling and thus causing all global shortcuts to break. It should return True only for keypresses it actually handled or specifically wants to be ignored.

comment:3 Changed 10 years ago by garycmartin

Just to confirm (I commented in #2253 before spotting this ticket) that the current release of Calculate-32 fixed this, it's likely the wiki.laptop.org update pages are pointing to an old release. Would rather someone from olpc OKayed changing the update page as it implies some level of olpc support/selection of a version (I personally tested back to build 767).

comment:4 Changed 10 years ago by virtusanqa

@garycmartin - The calculator version which i tested was Calculate-30

Test Environment
OS: Sugar and GNOME (Dual boot)
Machine Type: XO 1.5
Build: OS 851
Firmware: Q3A50

comment:5 Changed 10 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed in a past release, closing.

Note: See TracTickets for help on using tickets.