Opened 9 years ago

Closed 22 months ago

#2212 closed defect (fixed)

Words displays incorrect translation for words that are not in the dictionay

Reported by: carrott Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Words Version: Unspecified
Severity: Unspecified Keywords: dextrose, 12.10
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by carrott)

Words-4 on os373pyg on XO-1

Start a new session of Words, the default languages should be English->Spanish

Type "mascot", the translation will be "chew" which is incorrect.

This appears to be because mascot matches the Spanish word mascar which has a reverse translation of chew in english.

When the word to translate no longer matches a word in the dictionary, the last matching (partial or otherwise) translation should not be shown.

Change History (10)

comment:1 Changed 9 years ago by bernie

  • Component changed from untriaged to Words
  • Owner set to cjb
  • Status changed from new to assigned

comment:2 Changed 8 years ago by RafaelOrtiz

Just adding mascot mascota on spanish.txt file shoudl do to fix this.

comment:3 Changed 8 years ago by RafaelOrtiz

  • Owner changed from cjb to RafaelOrtiz

comment:4 in reply to: ↑ description Changed 8 years ago by RafaelOrtiz

  • Description modified (diff)

Replying to carrott:

Words-4 on os373pyg on XO-1

Start a new session of Words, the default languages should be English->Spanish

Type "mascot", the translation will be "chew" which is incorrect.

This appears to be because mascot matches the Spanish word mascar which has a reverse translation of chew in english.

When the word to translate no longer matches a word in the dictionary, the last matching (partial or otherwise) translation should not be shown.

comment:5 Changed 8 years ago by carrott

  • Description modified (diff)

Rafael, please don't change the description unless the problem is unclear or badly described. Please add your comments and proposed solutions as comments on the ticket.

Rafael's comment:

I don't know if this is the right thing to do, imho i preffer to have 'a' suggestion than nothing.

i think the right thing to do here is keep adding things to the .txt files in order to have a broader DB for words.

comment:6 Changed 8 years ago by carrott

I don't think it will be possible to have every word in the dictionary, including misspellings and slang.

I think having the suggestion disappear or be replaced by "No Translation" as soon as the input word does not match will be easily understood by the user. The current situation isn't good because the activity does not have any basis for these "suggestions". Currently it chooses a seemingly random word and does not alert the user that it very probably has nothing to do with the input word.

comment:7 Changed 8 years ago by RafaelOrtiz

Ok I hit reply unintentionally. about your request i guess it's fine to have a new version of words that shows a message of No Translation when the word is not on the dictionary.

Leaving this open till a new version of words have this fixed.


comment:8 Changed 8 years ago by RafaelOrtiz

Other option is to have a color indication for words not in the dict.

comment:9 Changed 7 years ago by godiard

  • Keywords 12.10 added

comment:10 Changed 22 months ago by quozl

  • Resolution set to fixed
  • Status changed from assigned to closed

With current version, "mascot" is untranslated, and this seems fine.

Note: See TracTickets for help on using tickets.