Opened 10 years ago

Closed 10 years ago

#2209 closed defect (fixed)

os373pyg on XO-1 shows linux startup messages rather than sugar splashscreen

Reported by: carrott Owned by: ayush
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: untriaged Version: Unspecified
Severity: Unspecified Keywords: dextrose
Cc: Distribution/OS: Dextrose
Bug Status: Resolved

Description

os373pyg on XO-1 starts up with white text on black background with a penguin in the corner. os300py had the white turning with circle of dots splashscreen. os373pyg on XO-1.5 has the expected spashscreen.

Change History (7)

comment:1 Changed 10 years ago by bernie

  • Resolution set to notabug
  • Status changed from new to closed

I see the splashscreen all right on my XO-1.

Are you sure it wasn't just after upgrading? You get the text console every time you unfreeze the display in ofw before booting.

Closing this ticket as "notabug", but please reopen it if my guess was wrong.

comment:2 Changed 10 years ago by tonyforster

  • Resolution notabug deleted
  • Status changed from closed to reopened

My OS373pyg boots with white text on black background and picture of Tux instead of the 'clock'. I don't mind that display though. Its consistent with an education policy of exposing the workings.

comment:3 Changed 10 years ago by carrott

Yes, this happens on every boot, not just the first time, and on all of our XO-1.

Before the white on black screen with penguin, there is text in black on white saying

Boot Device:/pci....

which I think is the OFW boot parameters?

comment:4 Changed 10 years ago by seeta

  • Owner set to ayush
  • Status changed from reopened to assigned

comment:5 Changed 10 years ago by bernie

According to dsd & cjb, this behavior was only temporary

<bernie> dsd_, cjb: now that laptops are being shipped unlocked to deployments, shouldn't we change olpc-utils to never automatically unfreeze? the ofw can unfreeze the display by simply holding a button during boot.
<dsd_> bernie: olpc.fth doesnt unfreeze the screen
<dsd_> it did in 1 pre-10.1.2 build for #9100 diagnosis, but thats it
<cjb> bernie: agree
<dsd_> cjb: but you also agree that the work is already done?
* [scs]_ is now known as [scs]
<bernie> dsd_: did I pull olpc-bootanim at a very unlucky moment? :-)
<cjb> ah, still reading, hang on
<cjb> yes, OFW is pretty-boot by default, since last year or so

comment:6 Changed 10 years ago by bernie

This bug will be fixed in next Dextrose public build.

comment:7 Changed 10 years ago by bernie

  • Bug Status changed from Unconfirmed to Resolved
  • Distribution/OS changed from Unspecified to Dextrose
  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.