Opened 10 years ago

Closed 10 years ago

#2204 closed enhancement (fixed)

View source - which one?

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: rgs Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

A discussion of issues only:

Currently View source shows a Logo representation of the 'document'. It is not a true source, rather an alternate representation. There is another easy way to view the Logo representation, save Logo to Journal.

I think only Browse and TA show the document rather than the Activity source.

The show source of other activities has improved lately, showing files and directories. Still, likely to be of interest more to secondary students.

Block stacks can be copied to the clipboard and pasted into write but I could not find a way to copy the ta file into a word processor without leaving Sugar. I thought there was a way? (Editing the ta file can be handy, its the only way I could find to remove a second turtle)

Questions, would either of the Python source or the ta file be more useful than Logo for View source?

Is there an easy way to edit the ta file?


Change History (9)

comment:1 in reply to: ↑ description Changed 10 years ago by garycmartin

Replying to tonyforster:

Questions, would either of the Python source or the ta file be more useful than Logo for View source?

Did you mean ta or Logo source? Note that in activities that provide custom source, the view source window has two buttons, one for 'Instance Source' (Logo in TA), and one for 'Activity Bundle Source' (Python and other files in the activity bundle).

comment:2 Changed 10 years ago by walter

  • Cc rgs added

Maybe we need to add a third source: the ta project?

Re removing the turtle, we are tracking that in ticket #2191

comment:3 Changed 10 years ago by tonyforster

Oops, I did not notice the instance source button. Sorry. Arguably, the *.ta project source is a truer representation of the 'source' than the Logo. A third button would be good.

comment:4 Changed 10 years ago by walter

Haven't yet figured uot how t add a third button. Maybe it is easier to put multiple files in the current button?

comment:5 follow-up: Changed 10 years ago by walter

Since we have a save_to_logo button, maybe it would make more sense to dedicate view_source to the ta file???

comment:6 in reply to: ↑ 5 Changed 10 years ago by tonyforster

Replying to walter:

Since we have a save_to_logo button, maybe it would make more sense to dedicate view_source to the ta file???

Yes

comment:7 Changed 10 years ago by walter

Done (except since the window scrolls horizontally instead of wraps, it is not very easy to read). I may add newlines which I'll remove when importing the json data.

http://git.sugarlabs.org/projects/turtleart/repos/mainline/commits/668bba65b0a17ba9883150bc8bf7b18b7b7fd6f7

comment:8 Changed 10 years ago by walter

I've added a newline between blocks in the ta code output to make it easier to read... I think this one is all set. Will be in v100.

http://git.sugarlabs.org/projects/turtleart/repos/mainline/commits/ee81d0497d102e0a749261fe5d23481f1d5d3cf3

comment:9 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.