Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#2197 closed defect (fixed)

livecd-iso-to-disk should be installed at /LiveOS/ of base filesystem

Reported by: FGrose Owned by: mchua pbrobinson sdz
Priority: Unspecified by Maintainer Milestone:
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Unspecified Keywords:
Cc: satellit Distribution/OS: Fedora
Bug Status: New

Description

Placing the installation script in the 'outer' filesystem would allow for loop mounting the downloaded .iso image file and running an installation with the onboard script.

(http://lists.sugarlabs.org/archive/soas/2010-May/001283.html)

Change History (5)

comment:1 Changed 10 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Cc satellit added
  • Milestone changed from Unspecified by Release Team to Mango Lassi

Fedora-13-x86_64-Live-SoaS.iso has the file in the requested location.

[root@localhost ~]# losetup /dev/loop0 /media/VMs/Fedora-13-x86_64-Live.iso 
[root@localhost ~]# mount /dev/loop0 /mnt/fs/
mount: warning: /mnt/fs/ seems to be mounted read-only.
[root@localhost ~]# ls -la /mnt/fs/
total 30
dr-xr-xr-x. 5 root root  2048 May 12 22:05 .
drwxr-xr-x. 3 root root  4096 Sep 24 08:55 ..
dr-xr-xr-x. 3 root root  2048 May 12 22:05 EFI
-r--r--r--. 1 root root 18363 May 12 22:05 GPL
dr-xr-xr-x. 2 root root  2048 May 12 22:05 isolinux
dr-xr-xr-x. 2 root root  2048 May 12 22:05 LiveOS
[root@localhost ~]# ls -la /mnt/fs/LiveOS/
total 676231
dr-xr-xr-x. 2 root root      2048 May 12 22:05 .
dr-xr-xr-x. 5 root root      2048 May 12 22:05 ..
-r-xr-xr-x. 1 root root     23040 May 12 22:05 livecd-iso-to-disk
-r-xr-xr-x. 1 root root      8192 May 12 22:05 osmin.img
-r-xr-xr-x. 1 root root 692424704 May 12 22:07 squashfs.img

While Fedora-13-i686-Live-SoaS.iso does not and requires 2 extra loop mounts:

[root@localhost ~]# losetup /dev/loop1 /media/VMs/Fedora-13-i686-Live-SoaS.iso 
[root@localhost ~]# mkdir /mnt/soas/
[root@localhost ~]# mount /dev/loop1 /mnt/soas/
mount: warning: /mnt/soas/ seems to be mounted read-only.
[root@localhost ~]# ls -la /mnt/soas/
total 12
dr-xr-xr-x. 5 root root 2048 May 13 16:01 .
drwxr-xr-x. 4 root root 4096 Sep 24 14:36 ..
dr-xr-xr-x. 3 root root 2048 May 13 16:00 EFI
dr-xr-xr-x. 2 root root 2048 May 13 16:00 isolinux
dr-xr-xr-x. 2 root root 2048 May 13 16:02 LiveOS
[root@localhost ~]# ls -la /mnt/soas/LiveOS/
total 472276
dr-xr-xr-x. 2 root root      2048 May 13 16:02 .
dr-xr-xr-x. 5 root root      2048 May 13 16:01 ..
-r-xr-xr-x. 1 root root      8192 May 13 16:02 osmin.img
-r-xr-xr-x. 1 root root 483598336 May 13 16:03 squashfs.img
[root@localhost ~]# losetup /dev/loop2 /mnt/soas/LiveOS/squashfs.img 
[root@localhost ~]# mkdir /mnt/squash/
[root@localhost ~]# mount /dev/loop2 /mnt/squash/
mount: block device /dev/loop2 is write-protected, mounting read-only
[root@localhost ~]# ls -la /mnt/squash/
total 4
drwx--S---. 3 root 101737   29 May 13 16:02 .
drwxr-xr-x. 5 root root   4096 Sep 24 14:37 ..
drwxr-sr-x. 2 root 101737   33 May 13 16:02 LiveOS
[root@localhost ~]# ls -la /mnt/squash/LiveOS/
total 1512960
drwxr-sr-x. 2 root 101737         33 May 13 16:02 .
drwx--S---. 3 root 101737         29 May 13 16:02 ..
-rwxr-xr-x. 1 root 101737 4294967296 May 13 16:02 ext3fs.img
[root@localhost ~]# losetup /dev/loop3 /mnt/squash/LiveOS/ext3fs.img 
[root@localhost ~]# mkdir /mnt/ext3fs/
[root@localhost ~]# mount /dev/loop3 /mnt/ext3fs/
mount: block device /dev/loop3 is write-protected, mounting read-only
[root@localhost ~]# ls -la /mnt/ext3fs/
total 136
dr-xr-xr-x. 22 root root  4096 May 13 16:02 .
drwxr-xr-x.  6 root root  4096 Sep 24 14:39 ..
dr-xr-xr-x.  2 root root  4096 May 13 15:58 bin
dr-xr-xr-x.  4 root root  4096 May 13 16:01 boot
drwxr-xr-x.  4 root root  4096 Oct  1  2009 dev
drwxr-xr-x. 90 root root  4096 May 13 16:01 etc
-rw-r--r--.  1 root root 18363 May 13 16:01 GPL
drwxr-xr-x.  2 root root  4096 Oct  1  2009 home
dr-xr-xr-x. 17 root root 12288 May 13 15:58 lib
drwxr-xr-x.  2 root root  4096 May 13 16:01 LiveOS
drwx------.  2 root root 16384 May 13 15:54 lost+found
drwxr-xr-x.  2 root root  4096 Oct  1  2009 media
drwxr-xr-x.  2 root root  4096 Oct  1  2009 mnt
-rw-r--r--.  1 root root     0 May 13 16:01 null
drwxr-xr-x.  2 root root  4096 Oct  1  2009 opt
drwxr-xr-x.  2 root root  4096 May 13 15:54 proc
dr-xr-x---.  2 root root  4096 May 13 15:55 root
dr-xr-xr-x.  2 root root 12288 May 13 15:58 sbin
drwxr-xr-x.  2 root root  4096 May 13 16:01 selinux
drwxr-xr-x.  2 root root  4096 Oct  1  2009 srv
drwxr-xr-x.  2 root root  4096 May 13 15:54 sys
drwxrwxrwt.  2 root root  4096 May 13 16:01 tmp
drwxr-xr-x. 13 root root  4096 May 13 15:55 usr
drwxr-xr-x. 19 root root  4096 May 13 15:59 var
[root@localhost ~]# ls -la /mnt/ext3fs/LiveOS/
total 32
drwxr-xr-x.  2 root root  4096 May 13 16:01 .
dr-xr-xr-x. 22 root root  4096 May 13 16:02 ..
-rwxr-xr-x.  1 root root 23040 May 13 16:01 livecd-iso-to-disk

This eases installation from a Linux system by allowing one to use the livecd-iso-to-disk installer without an additional download and without burning a CD-ROM.

comment:2 Changed 10 years ago by FGrose

Sorry, as the transcripts show, Fedora-13-x86_64-Live.iso has the script in the desired location, but Fedora-13-x86_64-Live-SoaS.iso does NOT.

comment:3 Changed 10 years ago by FGrose

  • Milestone changed from Mango Lassi to Future SoaS Releases

comment:4 Changed 9 years ago by pbrobinson

  • Resolution set to fixed
  • Status changed from new to closed

This is resolved in SoaSv5 which is due out soon.

comment:5 Changed 7 years ago by dnarvaez

  • Milestone Future deleted

Milestone Future deleted

Note: See TracTickets for help on using tickets.