Opened 10 years ago

Closed 10 years ago

#2191 closed enhancement (fixed)

clean should set scale =33

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

clean should set scale =33? because it resets just about everything else

Change History (10)

comment:1 Changed 10 years ago by walter

Right. Will incorporate into v95.

comment:2 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 10 years ago by tonyforster

  • Resolution fixed deleted
  • Status changed from closed to reopened

maybe reset polar and cartesian too?
maybe delete multiple turtles? I cant see another way to delete them other than editing the ta file.

comment:4 Changed 10 years ago by walter

I'm now (experimental v95 in the wiki) hiding the coordinate overlays on clean... not sure I like it, but let's see what others think.

Re deleting (hiding) the turtles on clean, I'm working on this, but it is a bit tricky because of the way in which turtles are hidden and revealed during the execution of the logo code. I'll look at the code again in the morning with fresher eyes.

comment:5 Changed 10 years ago by walter

The current experimental v95 hides all but the default turtle and the currently active turtle on clean. Still needs a bit of fine-tunning. The extra turtles are still in the project, however, and will reappear at load time.

Would it make sense to delete turtles by dragging them onto the palette, the way we delete blocks?

comment:6 Changed 10 years ago by tonyforster

Re polar and cartesian, I don't have a strong view either way, it was more a question.

Yes, dragging turtles to the pallet might be good, but not turtle1. The reason I didn't suggest it myself is that it took me a long time to think of it so maybe its not so intuitive.

comment:7 Changed 10 years ago by walter

I'll experiment with dragging turtles to the palette (but not turtle 1). I may have to change the level at which the turtle is displayed so that it will appear over the palette during the drag.

Please experiment with the clean-hides-the-coordinate-overlays patch and let me know what you think. It may be that we only want to invoke it when the overlay was displayed with a block as opposed to from the toolbar. Any feedback would be appreciated.

comment:8 Changed 10 years ago by walter

Turtles dragged onto the palette are removed (with the exception of the default turtle)

comment:9 Changed 10 years ago by tonyforster

downloaded http://wiki.sugarlabs.org/images/3/37/TurtleArt-95.xo
but clean does not hide coordinates and turtles are not removed. Maybe getting old cached copy. There is a bug about not being able to downgrade activities but I havent noticed an error log.

comment:10 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.