Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#2183 closed defect (wontfix)

Speak's robot is missing a lot of nouns in os300py on XO-1

Reported by: carrott Owned by: jminor
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Speak Version: Unspecified
Severity: Minor Keywords: dextrose
Cc: alsroot Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

"Where are you?" results in "I'm in the sugar communities computer in ..., where are you?"

"how old are you?" results in "I was connected to the net on"

"can you breathe?" results in "My favourite group is"

"what is the date?" and "what year is it?" results in "Today is"

"where do you live?" results in "I am living in, where are you?"

Change History (4)

comment:1 Changed 9 years ago by seeta

  • Status changed from new to assigned

comment:2 Changed 9 years ago by alsroot

  • Cc alsroot added

comment:3 Changed 8 years ago by alsroot

  • Resolution set to wontfix
  • Status changed from assigned to closed

The problem is that PyAIML keeps entirely db in memory and even with restricted Alice db, it might crash due to lack of free memory (see #2533). I'm afraid there is no way to fix this issue on XO-1, at least while Speak uses PyAIML.

comment:4 Changed 8 years ago by RafaelOrtiz

Shame but truth for XO-1. We will keep a look onto http://pyaiml.sourceforge.net

to see what can be done here.

Note: See TracTickets for help on using tickets.