Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#2180 closed defect (fixed)

Sugar emulator, when run on 800x600 resolution, faces cropping

Reported by: dipankar Owned by: dipankar
Priority: High Milestone:
Component: Sugar Version: 0.88.x
Severity: Major Keywords:
Cc: aslroot, dfarning, sascha, tomeu Distribution/OS: Ubuntu
Bug Status: Assigned

Description (last modified by dipankar)

Bug Description:
When the system resolution is changed to 800x600, and the emulator is ran, the emulator window is pushed down out of visible area. This leads to a situation where the bottom portion of the emulator is not visible.

This is a specific issue that only happens because the emulator resolution is the same at the monitor resolution.

Probable reason:
The task panels of Ubuntu and title bar of emulator window, are pushing the window downward, leaving reduced visible space for sugar.

Steps to reproduce:

  1. Set the system resolution to 800x600.
  2. Start the emulator.
  3. Some portion from bottom in Sugar is not visible.

Attachments (1)

0001-fullscreen-workaround.-Ticket-2180.patch (889 bytes) - added by dipankar 9 years ago.
workaround patch for the bug

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by dipankar

  • Owner changed from tomeu to dipankar
  • Status changed from new to assigned

comment:2 Changed 9 years ago by dipankar

  • Distribution/OS changed from Unspecified to Ubuntu

Changed 9 years ago by dipankar

workaround patch for the bug

comment:3 Changed 9 years ago by dipankar

  • Bug Status changed from Unconfirmed to New
  • Cc sascha tomeu added
  • Keywords r? added; fullscreen cropping removed

Patch uploaded and requesting for review

comment:4 Changed 9 years ago by sascha_silbe

Looks good to me. While it's still not a complete fix, it's about as good as we can do (since we can't know the size of the window decorations).

comment:5 Changed 9 years ago by tomeu

  • Keywords r! added; r? removed

What happened with adjusting the grid cell size so the UI fits in 800x600?

comment:6 Changed 9 years ago by dipankar

  • Bug Status changed from New to Assigned
  • Description modified (diff)
  • Milestone changed from Unspecified by Release Team to 0.88
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major

comment:7 Changed 9 years ago by sascha_silbe

  • Keywords r? added; r! removed

comment:8 Changed 8 years ago by tomeu

  • Keywords r! added; r? removed

The code change looks good to me, but please attach first one with an appropriate commit message.

comment:9 Changed 8 years ago by dipankar

I have sent the proper patch based on mainline to sugar-devel mailing list.
Requesting a review.

comment:10 Changed 8 years ago by sascha_silbe

  • Keywords r! removed
  • Milestone changed from 0.88 to 0.90
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by 1d069eb (master) / 1cce2c7 (sucrose-0.90).

comment:11 Changed 6 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.