Opened 9 years ago

Closed 6 years ago

#2162 closed enhancement (obsolete)

Allow Cancel from the Stop dialog called "Name this entry"

Reported by: skierpage Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords: UI
Cc: walter Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

I'm running OLPC's build os851 (10.1.2 release candidate that incorporates Sugar 0.84.16) on an XO-1.

If I start an activity and Ctrl-Q by mistake, I get a "Name this entry" dialog.
Two problems:

  1. The dialog doesn't reflect the fact that I'm about to quit, it looks like I'm just naming a Journal entry. Maybe it should have the Stop icon in it somewhere.
  2. There's no way to say "I don't want to Stop, I made a mistake!" No matter what I do, the activity will exit. This is unlike the Quit (or File save as...) dialog in every other OS.

On the other hand... It seems if I resume a named Journal entry, I don't get a dialog. So maybe it would be inconsistent to sometimes be able to cancel Stopping an activity and sometimes not.

Change History (2)

comment:1 Changed 9 years ago by garycmartin

  • Cc walter added
  • Type changed from defect to enhancement

FWIW Walter has been working on a way to replace the naming dialogue with an optional naming dialogue / details view that can be opened/closed at any time by the user. This would avoid the common 'dialogue is getting in the way' cases, while allowing the activity name/description/tags to be edited and re-edited at more appropriate times for a given task (or not at all). Due to activity id complications I can't see this landing in time for the Sugar 0.90 feature freeze.

comment:2 Changed 6 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

We don't have the dialog anymore.

Note: See TracTickets for help on using tickets.