Opened 10 years ago

Closed 7 years ago

#2153 closed defect (obsolete)

Browse fails to start from one of its journal entries

Reported by: bernie Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: dextrose
Cc: jasg Distribution/OS: Unspecified
Bug Status: New

Description

Even if the journal entry is buggy, Browse should be tolerant and not crash. I'll attach the journal object later.

This what we've found in the logs:

/usr/lib/python2.6/site-packages/hulahop/webview.py:56: Warning: invalid uninstantiatable type `(null)' in cast to `GtkWidget'
  self.web_view.get_toplevel().destroy()
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed
  self.web_view.get_toplevel().destroy()
/usr/lib/python2.6/site-packages/hulahop/webview.py:56: GtkWarning: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed
  self.web_view.get_toplevel().destroy()
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gtk-2.0/gobject/__init__.py", line 108, in obj_set_property
    prop.setter(self, value)
  File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 365, in set_active
    self.save()
  File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 600, in save
    preview = self.get_preview()
  File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 548, in get_preview
    width, height = pixmap.get_size()
AttributeError: 'NoneType' object has no attribute 'get_size'

Change History (5)

comment:1 Changed 10 years ago by lucian

  • Bug Status changed from Unconfirmed to New
  • Component changed from Browse to sugar-toolkit
  • Owner changed from lucian to erikos

From the logs, this seems to be a sugar-toolkit bug. Please attach the full log to make sure and report your Sugar and Browse versions.

comment:2 Changed 10 years ago by bernie

sugar-toolkit-0.88.1.

I no longer have the full log, but the part I quoted in the bug already seems to point at the right place:

  File "/usr/lib/python2.6/site-packages/sugar/activity/activity.py", line 548, in get_preview
    width, height = pixmap.get_size()
AttributeError: 'NoneType' object has no attribute 'get_size'
537         """Returns an image representing the state of the activity. Generally
538         this is what the user is seeing in this moment.
539 
540         Activities can override this method, which should return a str with the
541         binary content of a png image with a width of 300 and a height of 225
542         pixels.
543         """
544         if self.canvas is None or not hasattr(self.canvas, 'get_snapshot'):
545             return None
546         pixmap = self.canvas.get_snapshot((-1, -1, 0, 0))
547 
548         width, height = pixmap.get_size()
}}

comment:3 Changed 10 years ago by seeta

  • Status changed from new to assigned

comment:4 Changed 7 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:5 Changed 7 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from assigned to closed

From the log this doesn't seem to be related to the journal entry, it's failing to make a screenshot. Hard to say why without being able to reproduce.

Note: See TracTickets for help on using tickets.