Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#2142 closed defect (fixed)

GConf-dbus doesn't like gettext_domain in schema

Reported by: timclicks Owned by: sascha_silbe
Priority: High Milestone:
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Blocker Keywords:
Cc: Distribution/OS: Fedora
Bug Status: New

Description

I am running Fedora 13 in a VM. When I run sugar-emulator, Metacity crashes. Sugar does load, but apport reports a bug.

[tim@sugar Sugar]$ ./sugar-jhbuild run sugar-emulator
Warning: unknown distro version, automatic fallback to rawhide.
1280739461.70416 STARTUP: Starting the shell
Window manager warning: Could not parse font description "(null)" from GConf key /apps/metacity/general/titlebar_font
Window manager warning: 0 stored in GConf key /apps/metacity/general/num_workspaces is out of range 1 to 36
**

Attachments (2)

path (1.3 KB) - added by tomeu 9 years ago.
/etc/gconf/2/path in F13
0001-Add-patch-for-GConf-to-tolerate-a-new-attribute-adde.patch (2.8 KB) - added by tomeu 9 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by tomeu

Looks like the GConf you are using is not finding the metacity schema, thus missing the default values.

I'm not sure there's anything inside Sugar that can be done about it, but I'm not sure to which component reassign this to.

comment:2 Changed 9 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Component changed from sugar to sugar-jhbuild
  • Milestone changed from Unspecified by Release Team to not applicable
  • Owner changed from tomeu to sascha_silbe
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Blocker
  • Status changed from new to accepted
  • Summary changed from metacity crahsing sugar-jhbuild run sugar-emulator to wrong GConf-dbus paths on Fedora 13

This is an issue with GConf-dbus using different paths than the distro-shipped GConf on Fedora 13. I already fixed a similar one for Debian, but apparently Fedora 13 uses yet another directory.

Tim, can you paste the contents of /usr/share/gconf/default.path (or wherever Fedora put that file), please?

Changed 9 years ago by tomeu

/etc/gconf/2/path in F13

comment:3 Changed 9 years ago by jedierikb

Is the workaround to install fedora 12?

comment:4 follow-up: Changed 9 years ago by sascha_silbe

The workaround is:

cd sugar-jhbuild
rm -rf install
./sugar-jhbuild build -n --skip=GConf-dbus

This will break SUGAR_PROFILE support (i.e. running multiple Sugar instances under the same user account in parallel).

comment:5 in reply to: ↑ 4 Changed 9 years ago by tomeu

Replying to sascha_silbe:

The workaround is:

cd sugar-jhbuild
rm -rf install
./sugar-jhbuild build -n --skip=GConf-dbus

This will break SUGAR_PROFILE support (i.e. running multiple Sugar instances under the same user account in parallel).

If we still want to support that, the attached patch fixes it.

comment:6 Changed 9 years ago by tomeu

  • Keywords r? added

comment:7 Changed 9 years ago by erikos

Patch from Tomeu works here fine!

comment:8 Changed 9 years ago by erikos

People interested in this - might be interested in in #2228, too.

comment:9 Changed 9 years ago by sascha_silbe

  • Keywords r? removed

Tomeu, thanks for the patch! I've pushed it as ae471ef.
Tim, please verify the issue is fixed for you now and close the ticket if it is.

comment:10 Changed 9 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from accepted to closed
  • Summary changed from wrong GConf-dbus paths on Fedora 13 to GConf-dbus doesn't like gettext_domain in schema

No response for two weeks; assuming the problem is gone.

comment:11 Changed 6 years ago by dnarvaez

  • Milestone not applicable deleted

Milestone not applicable deleted

Note: See TracTickets for help on using tickets.