Opened 10 years ago

Closed 8 years ago

#2126 closed defect (fixed)

Calculate plot image alignment glitch when previous results contain very long answers

Reported by: garycmartin Owned by: rwh
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

If a previous result is wider than the results widget (lower right side of screen scrollable results area), GTK+ seems to (secretly) mark the widget as wider than it visibly is (scrollbar still looks fine/visible); a subsequent plot will then be centred incorrectly based on the much wider widget, making it go potentially off screen right, see attached png. I was re-testing sci/eng mode (Calculate-31, Fedora 13, Sugar 0.88.1) at the time and had been entering very, very large numbers that scrolled the input area. A likely rare event, but worth a fix at some point.

Reinier couldn't reproduce this right at this time in his environment, so if you can double check please ping here and mark Bug Status as New (don't think this is a recent issue, is likely in Calculate-30 as well).

Attachments (1)

plot alignment issue if previous results are wider than results window.png (66.9 KB) - added by garycmartin 10 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 8 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in private branch to be pushed to mainline soon. Turned out to be a couple of cases where gtk.WRAP_WORD was used instead of the correct gtk.WRAP_WORD_CHAR.

Note: See TracTickets for help on using tickets.