Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2119 closed defect (fixed)

Measure waveform capture has missing area due to palette redraw

Reported by: quozl Owned by: walter
Priority: Unspecified by Maintainer Milestone:
Component: Measure Version:
Severity: Trivial Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

There is a small rectangle of screen that is missing from the waveform capture. This is where the palette for the button was.

Measure-30, XO-1 os301, XO-1.5 os206.

Attachments (2)

Waveform 1.png (38.7 KB) - added by quozl 10 years ago.
whistle capture on XO-1 showing missing rectangle below capture button
0001-avoid-race-that-leads-to-waveform-capture-image-corr.patch (4.6 KB) - added by quozl 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by quozl

whistle capture on XO-1 showing missing rectangle below capture button

comment:1 Changed 10 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

From the attached picture, it seems that the toolbar is not refreshing properly from the tooltip of the capture button. I am guessing it is a problem with either the Sugar toolbar or gdk. It doesn't seem to be a problem with Sugar 0.88 toolbars and it doesn't seem to show up when running Sugar 0.84 in the emulator. Not sure I can do anything about this.

comment:2 Changed 10 years ago by quozl

  • Resolution wontfix deleted
  • Status changed from closed to reopened

It will eventually happen with Sugar 0.88 given sufficiently slow hardware, and is not a problem with the toolbar implementation, but rather due to taking a screenshot by reading the root window without first ensuring the display is quiescent. The attached fix has been tested on XO-1 and XO-1.5 and fixes the symptom.

comment:3 Changed 10 years ago by walter

Sorry. I had misread the original ticket. I thought it was a problem with the display, which I couldn't reproduce, not the screenshot. I'll look at your patch. Thanks.

comment:4 Changed 10 years ago by quozl

Tested Measure git hash 74d81ce, the symptom is solved.

comment:5 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in v31

comment:6 Changed 10 years ago by quozl

Tested Measure-31, is fixed.

Note: See TracTickets for help on using tickets.