Opened 10 years ago

Closed 10 years ago

#2114 closed enhancement (fixed)

No Physics preview image in Journal detail page

Reported by: FGrose Owned by: garycmartin
Priority: Normal Milestone: Unspecified
Component: Physics Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Assigned

Description

Observed with Physics 5 on Fedora 13 in Xephyr window of Sugar 0.88.1 and on SoaS Mirabelle.

There is no snapshot of the the model to help distinguish Activity models.

Change History (3)

comment:1 Changed 10 years ago by garycmartin

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS changed from Fedora to Unspecified
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor
  • Type changed from defect to enhancement
  • Version changed from 0.88.x to Unspecified

Not aware of any pygame based activities saving thumbnails for journal, ping me if you know of one that does and I'll shamelessly copy the code ;) I've meant to look into this for a while so thanks for the nudge, I'm sure it can't be too difficult to implement this enhancement.

comment:2 Changed 10 years ago by garycmartin

  • Bug Status changed from New to Assigned

comment:3 Changed 10 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in Physics-6. There is an edge case due to the two runloops (gtk and pygame) that means the image is not guaranteed to be complete (preview can trigger part way through a re-draw if unlucky), but I'm hoping to resolve this when I move to Wade's sugargame replacement for the unmaintained olpcgame.

Note: See TracTickets for help on using tickets.