Opened 10 years ago

Closed 10 years ago

#2113 closed defect (fixed)

Ruler: scaled badly on XO

Reported by: dsd Owned by: walterbender
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Reproduced on F11 images for XO-1 and XO-1.5, the ruler is scaled badly. It's about 1/2 size.

This also means it does not fill the XO screen like it used to.

Additionally, the 2nd ruler is designed to start at (approx) 3.9cm on the screen, on the XO. This allows you to put an item at the very left edge of the XO (where the green plastic starts) and measure up to 18 cm. It worked this way in 8.2 but on F11 this ruler starts at 0 where the screen begins.

It would be worth you having a quick play with the old version and observing how the various rulers and measures line up with various corners of the XO screen, would be great to keep this behaviour.

Change History (2)

comment:1 in reply to: ↑ description Changed 10 years ago by garycmartin

Replying to dsd:

Additionally, the 2nd ruler is designed to start at (approx) 3.9cm on the screen, on the XO. This allows you to put an item at the very left edge of the XO (where the green plastic starts) and measure up to 18 cm. It worked this way in 8.2 but on F11 this ruler starts at 0 where the screen begins.

Wow, I never realised that, I've always just assumed that activity was broken and was offsetting it's drawing all wrong, I'd never have guessed the XO case was part of the measurement...

comment:2 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

The method I was using to detect OLPC hardware was no longer working. Fixed in v7 (also I scale the image to fit non-X displays too). Since we know the resolution of the XO, I don't display the spinner on the toolbar.

Note: See TracTickets for help on using tickets.