Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#2106 closed defect (fixed)

"sugar-control-panel -l" gives non-fatal error

Reported by: fran Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords: r+
Cc: Distribution/OS:
Bug Status: New

Description

When running "sugar-control-panel -l", I get the following output:

[fran@grackle ~]$ sugar-control-panel -l
ERROR:root:Exception while loading extension:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/jarabe/controlpanel/cmd.py", line 66, in load_modules
    globals(), locals(), ['model'])
  File "/usr/share/sugar/extensions/cpsection/modemconfiguration/model.py", line 19, in <module>
    from jarabe.model.network import GSM_USERNAME_PATH, GSM_PASSWORD_PATH, \
  File "/usr/lib/python2.6/site-packages/jarabe/model/network.py", line 306, in <module>
    class NMSettings(dbus.service.Object):
AttributeError: 'module' object has no attribute 'service'

network:
    networks (use the -c argument with this option)
    registration (use the -c argument with this option)
    jabber
    publish_information
    radio
aboutcomputer:
    aboutcomputer
    build_number
    firmware_number
    license
    serial_number
    wireless_firmware
datetime:
    timezone
aboutme:
    color
    color_xo
    nick
language:
    languages
keyboard:
frame:
    corner_delay
    edge_delay
updater:
power:
    automatic_pm
    extreme_pm

I've attached a small patch that fixes this.

Attachments (1)

network-py-dbus-service.diff (297 bytes) - added by fran 10 years ago.
Import dbus.service in network.py

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by fran

Import dbus.service in network.py

comment:1 Changed 10 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS Fedora deleted
  • Keywords r? added
  • Milestone changed from Unspecified by Release Team to 0.88.x
  • Severity changed from Unspecified to Minor

Bug confirmed, patch reviewed and tested. Tomeu, can you r+ this, please?

Fran, please remember to follow the Code Review process. In particular, please use "git format-patch" to produce the patch so the commit message gets included, and set the keyword r? so that the module maintainers will notice the patch.
Thanks for your ongoing work on fixing bugs, it's much appreciated!

comment:2 Changed 10 years ago by quozl

Affecting deployments, in particular teacher training, since it prevents clearing the registration with school server. Workaround being used is a brute-force rm(1) of .gconf. Fix tested on XO-1.5 with Sugar 0.84.

comment:3 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed

Thanks, please push.

comment:4 Changed 10 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, pushed.

comment:5 Changed 7 years ago by dnarvaez

  • Milestone 0.88.x deleted

Milestone 0.88.x deleted

Note: See TracTickets for help on using tickets.