Opened 11 years ago

Closed 8 years ago

#2100 closed defect (fixed)

sugar on 64 bit ubuntu clobbers mouse outside Sugar

Reported by: AndyHarrington Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

I had the exact same problem as another person who wrote on the Ubuntu forum: When I first started sugar on Ubuntu, the mouse was messed up and there was an ongoing problem thereafter *outside* of sugar: When I click the mouse inside a gnome window, I get the drag icon for the mouse, and I can drag the window. To get regular mouse that should not have a modified key, I need to press shift or Alt. Again this is outside of sugar and still happens after rebooting, and after removing sugar.

This is just a mouse issue. The alt and shift keys work fine for pure keyboard actions.

I am using ubuntu 10.4 on a new dual core 64 bit Intel machine from System 76. I added the sugar emulator 0.88.

Change History (3)

comment:1 Changed 11 years ago by sascha_silbe

Can you state explicitly what you were doing (especially the commands you entered), what happened and what you expected to happen?

This sounds like you ran sugar instead of sugar-emulator inside a Gnome session. sugar is a direct alternative to Gnome ("desktop environment"); you can't run both in the same session. What sugar-emulator does is setting up a "virtual" X server as a window of the current session (i.e. Gnome) and start sugar within that new session (inside the virtual X server).
Long story short: If you want to try out Sugar from within Gnome, please run sugar-emulator instead of sugar.

comment:2 Changed 11 years ago by AndyHarrington

What I downloaded was sugar-emulator. I did not download or install sugar. After downloading the emulator I ran it from the applications menu -> educaton->.... The sugar opening window that came up was non-responsive to the mouse. I forget if the close button worked or I ended up killing the process. After that I got the strange mouse behavior permanently.

comment:3 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.