Opened 9 years ago

Last modified 5 years ago

#2016 new defect

My Settings on top lost focus with popup

Reported by: jlew Owned by: tomeu
Priority: Low Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The My Settings window is always on top of all other windows. When network manager prompts the user for a network key using its popup, you cannot close the My Settings as the network manager popup is blocking key and mouse presses to My Settings, at the same time the popup is being covered by the My Settings overlay.

This error is hard to reproduce due to it being a timing issue or a network issue.

When this occurred, the my settings was loading just as the network popup was displayed.

XO1.5 os build 124
Sugar 0.84.16

Change History (1)

comment:1 Changed 5 years ago by tch

  • Priority changed from Unspecified by Maintainer to Low

I tried to reproduced this in Sugar 0.101.6, and I couldn't

This is what I tried:

  1. in sugar neighborhood view, connect to a secured AP typing a wrong password.
  2. right after that, right-click on the buddy icon and open "My Settings"
  3. the password dialog appears on top of the "My Settings" window.

Played with the timing but couldn't reproduce this.

I wonder if this is related to #3188

Note: See TracTickets for help on using tickets.