Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#201 closed defect (fixed)

Bounce opens and reads too many icons

Reported by: RafaelOrtiz Owned by: RafaelOrtiz
Priority: High Milestone:
Component: Sugar Version: 0.82.x
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

from http://dev.laptop.org/ticket/8658

please read important info there and then close it there when finished
in the 2 places...maybe doing the follow up in here.

Change History (9)

comment:1 Changed 12 years ago by gregdek

  • Bug Status set to New
  • Distribution/OS set to Unspecified
  • Milestone set to 0.84
  • Priority changed from normal to High
  • Severity set to Major

From the parent bug:

"strace shows that Bounce opens and reads over 100 icons that it clearly doesn't need, from places like /usr/share/icons/sugar/scalable/device/battery-030.icon . (unexplored avenue: other activities may do this as well.) "

This could be an ugly performance issue, and given that we have intractable performance issues like Python Slowness, this could be a big win. Assigning to 0.84 to see if we can have a look, but I'm guessing we'll have to push it to 0.86. Maybe some intrepid soul can do the analysis here.

comment:2 follow-up: Changed 12 years ago by wadeb

I'm pretty sure this was happening to *all* activities, not just Bounce. However, I tried the strace myself on 8.2.0 and was unable see the icon loads.

comment:3 in reply to: ↑ 2 Changed 12 years ago by tomeu

Replying to wadeb:

I'm pretty sure this was happening to *all* activities, not just Bounce. However, I tried the strace myself on 8.2.0 and was unable see the icon loads.

Actually, I saw it happening once but then couldn't reproduce.

I guess this happens because gtk cannot find the icon cache, so recreates it. This may have to do with rainbow. Maybe someone can check?

comment:4 Changed 12 years ago by erikos

If it is rainbow specific - one should be able to easily find out by turning off rainbow and compare.

comment:5 Changed 12 years ago by tomeu

  • Bug Status changed from New to Needinfo

comment:6 Changed 11 years ago by RafaelOrtiz

  • Milestone changed from 0.84 to 0.88

comment:7 Changed 11 years ago by erikos

  • Owner changed from marcopg to RafaelOrtiz
  • Status changed from new to assigned
  • Version changed from Unspecified to 0.82.x

Can someone test this again on the XO?

comment:8 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from assigned to closed

Tested again on the xo, bounce v7, strace not reproducible closing.

comment:9 Changed 8 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.