Opened 10 years ago

Closed 10 years ago

#1988 closed defect (wontfix)

TA mini won't install

Reported by: tonyforster Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Already have T blocks installed,
see also ticket 1987

inflating: /home/olpc/Activities/TurtleArtMini.activity/MANIFEST

caution: excluded filename not matched: mimetype
Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/jarabe/journal/palettes.py", line 118, in start_activate_cb

misc.resume(self._metadata)

File "/usr/lib/python2.6/site-packages/jarabe/journal/misc.py", line 165, in resume

registry.upgrade(bundle)

File "/usr/lib/python2.6/site-packages/jarabe/model/bundleregistry.py", line 403, in upgrade

self.install(bundle)

File "/usr/lib/python2.6/site-packages/jarabe/model/bundleregistry.py", line 351, in install

install_path = bundle.install(install_dir)

File "/usr/lib/python2.6/site-packages/sugar/bundle/activitybundle.py", line 345, in install

os.path.basename(svg_file)))

OSError: [Errno 17] File exists

Change History (2)

comment:1 Changed 10 years ago by walter

This seems to be related to a Sugar bug (aslroot brought this to my attention; I'll track down which one) regarding activities that share a mime type that has been fixed in Sugar 0.88 (hence it didn't show up in my testing). I don't know that there is a fix possible other than either upgrading to a newer Sugar (I've marked the activity as 0.88 only for the time being) or to remove the mimetype, which would be a disservice to those using more recent versions of Sugar. We could possibly backport a patch to Sugar 0,84 with the intention of getting the problem addressed on the machines that are about to have 0.84 installed (the XO 1.5s, .py and .uy).

comment:2 Changed 10 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

Ticket #1394 has a patch to fix the mimetype problem. Not clear that there is much more I can do with the activity itself.

Note: See TracTickets for help on using tickets.