Opened 11 years ago

Closed 10 years ago

#1980 closed defect (fixed)

About Computer has text that does not wrap

Reported by: timclicks Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Trivial Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Navigate to Control Panel > About Computer > Copyright & License

You'll notice that the copyright attribution notice requires scrolling to view. There are also some issues with the notice itself, e.g. semi-colons instead of commas and capitalisation on the contributors.

|TestCase|
Navigate to Control Panel > About Computer > Copyright & License. Check that text does not require horizontal scrolling.

Attachments (3)

0001-Enabled-word-wrap-on-lengthy-gtk.Label.patch (1.6 KB) - added by timclicks 11 years ago.
Patch
0005-Correct-text-overflow.patch (1.4 KB) - added by timclicks 11 years ago.
0001-Fixed-text-overflow-padding.-Closes-sl-1980.patch (1.7 KB) - added by timClicks 10 years ago.
fix

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by timclicks

Patch

comment:1 follow-up: Changed 11 years ago by tomeu

  • Keywords r! added; r? removed

+ label_info.set_line_wrap(True)

Should this be label_copyright instead?

  • "Association Inc; Red Hat Inc; Collabora Ltd; "
  • "and Contributors.")

+ "Association Inc, Red Hat Inc, Collabora Ltd; "
+ "and contributors.")

Could you bring the issue to the mailing list? Preferably consulting whoever was involved in agreeing this string with the parties involved (Walter?).

comment:2 follow-up: Changed 11 years ago by walter

Actually, I think it should be:

© 2006-2010 One Laptop per Child Association, Red Hat, Inc., Collabora Ltd., Sugar Labs, and contributors

Not sure there is a real issue here re punctuation. Red Hat seems to prefer a . after Inc. and
Collabora uses a . after Ltd.

I think it is appropriate to include Sugar Labs.

And we should flip the calendar to 2010.

Most style guides I am aware of allow either , or ; for serial lists, where ; is used for phrases. But either way is OK.

Changed 11 years ago by timclicks

comment:3 in reply to: ↑ 1 Changed 11 years ago by timclicks

Replying to tomeu:

+ label_info.set_line_wrap(True)

Should this be label_copyright instead?

Urgh. Yes, of course. Have fixed with latest patch.

Could you bring the issue to the mailing list? Preferably consulting whoever was involved in agreeing this string with the parties involved (Walter?).

Will do tomorrow.

comment:4 in reply to: ↑ 2 Changed 11 years ago by timclicks

Replying to walter:

Actually, I think it should be:

© 2006-2010 One Laptop per Child Association, Red Hat, Inc., Collabora Ltd., Sugar Labs, and contributors

This string should now be what the patch proposes.

Not sure there is a real issue here re punctuation. Red Hat seems to prefer a . after Inc. and
Collabora uses a . after Ltd.

I think it is appropriate to include Sugar Labs.

And we should flip the calendar to 2010.

Most style guides I am aware of allow either , or ; for serial lists, where ; is used for phrases. But either way is OK.

Have gone with commas, as it's a list of names. Have also included the trailing full stops.

comment:5 Changed 10 years ago by skierpage

This happens on the XO-1 in OLPC's build os851 (10.1.2 release candidate) that incorporates Sugar 0.84.16. The copyright text is clipped at "and Contribut". There doesn't seem to be any way to scroll or pan horizontally to see the rest of the text. The fix timclicks proposes for this (add label_copyright.set_line_wrap(True)) is not in that build's code.

comment:6 follow-up: Changed 10 years ago by skierpage

I made the add label_copyright.set_line_wrap(True) fix on my XO-1 and the copyright line in About my Computer wraps and is entirely visible. There's still some oddness because it and the "Sugar is the graphical user interface..." text have a much wider right margin than the Full license text underneath when you expand it.

comment:7 in reply to: ↑ 6 ; follow-up: Changed 10 years ago by timClicks

Thanks for keeping the motivation up.

Replying to skierpage:

There's still some oddness because it and the "Sugar is the graphical user interface..." text have a much wider right margin than the Full license text underneath when you expand it.

I think this is a little outside the scope of the original bug. But still an issue!

comment:8 in reply to: ↑ 7 Changed 10 years ago by timClicks

  • Keywords r? added; r! removed

Replying to timClicks:

I think this is a little outside the scope of the original bug. But still an issue!

I was wrong. Most recent patch fixes this too.

comment:9 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.