Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#1979 closed defect (notsugar)

Browse fails to enable text-entry focus on mouse click

Reported by: FGrose Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: 0.92.x
Severity: Unspecified Keywords: 11.3.0
Cc: bernie Distribution/OS: Fedora
Bug Status: New

Description

Observed when opening the login page for http://bugs.sugarlabs.org
or http://wiki.sugarlabs.org/index.php?title=Special:UserLogin&returnto=Special:UserLogout
or http://git.sugarlabs.org/login

I see the page and fields but can't activate the text boxes to
enter a login name, etc.

This has occurred intermittently in the past, but now seem to
occur almost always.

Adjusting the URI in the address bar from http://... to
https://... is a possible workaround, I've found, but for the wiki,
that takes us to an Ivan Krstić page.

Attachments (1)

log-1314242821.zip (269.0 KB) - added by FGrose 9 years ago.
logs

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Version changed from SoaS 3 (Mirabelle) to 0.88.x

Confirmed this defective behaviour in Fedora 13 sugar-emulator as well.

Noticed that when adjusting the URI address box entry to https://wiki.sugarlabs.org,
that the focus was visible immediately after the 'Enter' key was pressed and before
the other pages loaded.

comment:2 Changed 10 years ago by FGrose

Testing with soas-i386-20100507.02 and the problem does not present itself.

comment:3 follow-up: Changed 10 years ago by FGrose

This problem occurs with Sugar 0.88.1 on Fedora 13 in the sugar-emulator.

May it be related to https://bugzilla.redhat.com/show_bug.cgi?id=642941 and

#2096 ?

comment:4 in reply to: ↑ 3 Changed 10 years ago by erikos

Replying to FGrose:

This problem occurs with Sugar 0.88.1 on Fedora 13 in the sugar-emulator.

May it be related to https://bugzilla.redhat.com/show_bug.cgi?id=642941 and

#2096 ?

Seen the issue you are describing as well. But has nothing to do with the F14 bug I filed.

Changed 9 years ago by FGrose

logs

comment:5 Changed 9 years ago by FGrose

  • Summary changed from Browse fails to enable text-entry focus on login pages to Browse fails to enable text-entry focus on mouse click

This problem behavior continues to appear in Browse 124 on

olpc_build: OLPC OS 11.3.0 for XO-1.75, customized (build 40)
kernel_version: Linux version 3.0.0_xo1.75-20110822.1237.olpc.abfb0c5 (martin@…) (gcc version 4.6.0 20110226 (experimental) (GCC) ) #1 PREEMPT Mon Aug 22 12:41:54 EDT 2011

logs attached

I see it on the Browse Home page and I want to focus on one of the search entry fields.

My workaround is to focus in the Browse toolbar address control and then press the tab key to advance to the first or subsequent focus points.

comment:6 Changed 9 years ago by FGrose

  • Version changed from 0.88.x to 0.92.x

comment:7 Changed 9 years ago by erikos

  • Keywords 11.3.0 added
  • Milestone changed from Unspecified by Release Team to 0.94
  • Resolution set to notsugar
  • Status changed from new to closed

Thanks for reporting!

This will be fixed once the latest hulahop is in, currently building for ARM.

Sine this is a downstream issue I opened http://dev.laptop.org/ticket/11181 and close this one.

comment:8 Changed 7 years ago by dnarvaez

  • Milestone 0.94 deleted

Milestone 0.94 deleted

Note: See TracTickets for help on using tickets.