Opened 11 years ago

Closed 7 years ago

#1966 closed defect (fixed)

restart of NetworkManager results in shell.log message

Reported by: quozl Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Trivial Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

On Sugar 0.84.15, if NetworkManager is restarted while there is at least one access point in the mesh view, the shell.log contains a message:

1272267390.519734 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/sugar/extensions/deviceicon/network.py", line 309, in __ap_properties_changed_cb
    self._update_properties(properties)
  File "/usr/share/sugar/extensions/deviceicon/network.py", line 338, in _update_properties
    data = self._name + hex(self._flags)
TypeError: can only concatenate list (not "str") to list

There is no apparent effect of this message, and there's no indication that it causes a delay in reconnecting, but there is that possibility.

This section of the code has not been materially changed from 0.84 to 0.88. A variable renaming happened, is all. So there is a possibility it also may occur in 0.88.

Adding debugging code shows that _update_properties is occasionally called with a Ssid value that is not a string. The debugging code emits repr(self._name) when it is changed in _update_properties:

1272268032.860004 ERROR root: _update_properties: new self._name: dbus.ByteArray('quozl.linux.org.au', variant_level=1)
1272268090.983071 ERROR root: _update_properties: new self._name: dbus.Array([dbus.Byte(113), dbus.Byte(117), dbus.Byte(111), dbus.Byte(122), dbus.Byte(108), dbus.Byte(46), dbus.Byte(108), dbus.Byte(105), dbus.Byte(110), dbus.Byte(117), dbus.Byte(120), dbus.Byte(46), dbus.Byte(111), dbus.Byte(114), dbus.Byte(103), dbus.Byte(46), dbus.Byte(97), dbus.Byte(117)], signature=dbus.Signature('y'), variant_level=1)

Change History (6)

comment:1 Changed 11 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #1890. Sorry for not pasting the exception there (which you probably searched for).

comment:2 Changed 11 years ago by quozl

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Looks nothing like #1890, are you sure about this? #1890 fixes a logging statement. The exception in this ticket is not in a logging statement.

comment:3 Changed 11 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New

Sorry, you're right. The exception looked similar at first, but on second look is different.

comment:4 Changed 7 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from reopened to closed

Code seems to be changed a lot.

comment:5 Changed 7 years ago by quozl

  • Bug Status changed from New to Needinfo
  • Resolution obsolete deleted
  • Status changed from closed to reopened

Re-open for testing.

comment:6 Changed 7 years ago by quozl

  • Resolution set to fixed
  • Status changed from reopened to closed

Tested on 0.98, there is no delay in reconnecting when Network Manager is restarted, and the log messages seem benign. While the log is overly chatty about it, the extra storage available for chatty logs on modern systems compensates for the problem.

Note: See TracTickets for help on using tickets.